summaryrefslogtreecommitdiff
path: root/x11-plugins/wmblob/wmblob-1.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmblob/wmblob-1.0.3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmblob/wmblob-1.0.3.ebuild')
-rw-r--r--x11-plugins/wmblob/wmblob-1.0.3.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmblob/wmblob-1.0.3.ebuild b/x11-plugins/wmblob/wmblob-1.0.3.ebuild
new file mode 100644
index 000000000000..fe7b4768397e
--- /dev/null
+++ b/x11-plugins/wmblob/wmblob-1.0.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit autotools multilib
+
+DESCRIPTION="a fancy but useless dockapp with moving blobs"
+HOMEPAGE="http://freshmeat.net/projects/wmblob"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE=""
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11
+ x11-libs/libXpm
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xextproto
+ x11-libs/libXt"
+
+DOCS="AUTHORS ChangeLog NEWS README doc/how_it_works"
+
+src_prepare() {
+ sed -i \
+ -e "s:-O2:${CFLAGS}:g" \
+ -e "s:\$x_libraries:/usr/$(get_libdir):" \
+ configure.ac || die
+
+ eautoreconf
+}