summaryrefslogtreecommitdiff
path: root/x11-plugins/wmcpuwatch/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-02 14:45:16 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-02 14:45:16 +0000
commita70f42c65202d88c203c40910fef8f96f333d1ee (patch)
treede550ee3deb79c550ae1aba7fcce118d5d4dbc31 /x11-plugins/wmcpuwatch/files
parent721254b86a09bdedd5eefd0de7899c90ea2ead1a (diff)
gentoo resync : 02.01.2018
Diffstat (limited to 'x11-plugins/wmcpuwatch/files')
-rw-r--r--x11-plugins/wmcpuwatch/files/wmcpuwatch-0.2-cmake.patch33
1 files changed, 33 insertions, 0 deletions
diff --git a/x11-plugins/wmcpuwatch/files/wmcpuwatch-0.2-cmake.patch b/x11-plugins/wmcpuwatch/files/wmcpuwatch-0.2-cmake.patch
new file mode 100644
index 000000000000..bd3ddac62403
--- /dev/null
+++ b/x11-plugins/wmcpuwatch/files/wmcpuwatch-0.2-cmake.patch
@@ -0,0 +1,33 @@
+diff -Naur wmcpuwatch-0.2.orig/CMakeLists.txt wmcpuwatch-0.2/CMakeLists.txt
+--- wmcpuwatch-0.2.orig/CMakeLists.txt 2017-09-03 13:58:43.000000000 +0200
++++ wmcpuwatch-0.2/CMakeLists.txt 2018-01-01 22:28:19.108393247 +0100
+@@ -26,6 +26,7 @@
+ #
+ # Define include directories
+ include_directories(
++ "${PROJECT_BINARY_DIR}"
+ ${DOCKAPP_INCLUDE_DIR}
+ ${X11_X11_INCLUDE_PATH})
+
+@@ -56,8 +57,6 @@
+ install(TARGETS wmcpuwatch RUNTIME DESTINATION bin)
+ install(FILES wmcpuwatch.1 DESTINATION share/man/man1)
+ install(FILES wmcpuwatch.desktop DESTINATION share/applications)
+-install(FILES README.md DESTINATION share/doc/${CMAKE_PROJECT_NAME})
+-install(FILES ChangeLog DESTINATION share/doc/${CMAKE_PROJECT_NAME} RENAME changelog)
+
+ #
+ # Create a source tarball using CPack
+diff -Naur wmcpuwatch-0.2.orig/doc/CMakeLists.txt wmcpuwatch-0.2/doc/CMakeLists.txt
+--- wmcpuwatch-0.2.orig/doc/CMakeLists.txt 2017-09-03 12:00:37.000000000 +0200
++++ wmcpuwatch-0.2/doc/CMakeLists.txt 2018-01-01 22:33:00.690614708 +0100
+@@ -20,9 +20,6 @@
+ WORKING_DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}
+ COMMENT "Generating code documentation"
+ VERBATIM)
+-
+- # Install the documentation
+- install(DIRECTORY html DESTINATION share/doc/${CMAKE_PROJECT_NAME})
+ else (DOXYGEN_FOUND)
+ message("doxygen not installed: Not creating code documentation")
+ endif (DOXYGEN_FOUND)