summaryrefslogtreecommitdiff
path: root/x11-plugins/wmfishtime/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmfishtime/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmfishtime/files')
-rw-r--r--x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch60
-rw-r--r--x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch19
2 files changed, 79 insertions, 0 deletions
diff --git a/x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch b/x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch
new file mode 100644
index 000000000000..68d4c057c44e
--- /dev/null
+++ b/x11-plugins/wmfishtime/files/wmfishtime-1.24-gtk.patch
@@ -0,0 +1,60 @@
+diff -ur wmfishtime-1.24.orig/fishmon.c wmfishtime-1.24/fishmon.c
+--- wmfishtime-1.24.orig/fishmon.c 2004-05-13 02:55:59.000000000 +0300
++++ wmfishtime-1.24/fishmon.c 2008-01-12 16:19:34.000000000 +0200
+@@ -648,6 +648,7 @@
+
+ /* make a copy for the iconwin - parameters are the same */
+ memcpy(&attri, &attr, sizeof(GdkWindowAttr));
++ attri.window_type = GDK_WINDOW_CHILD;
+
+ sizehints.flags = USSize;
+ sizehints.width = 64;
+@@ -679,7 +680,6 @@
+ wmhints.window_group = win;
+ wmhints.flags =
+ StateHint | IconWindowHint | IconPositionHint | WindowGroupHint;
+- XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
+
+ bm.gc = gdk_gc_new(bm.win);
+
+@@ -693,6 +693,8 @@
+
+ gdk_window_show(bm.win);
+
++ XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
++
+ #undef MASK
+ } /* make_new_fishmon_dockapp */
+
+diff -ur wmfishtime-1.24.orig/Makefile wmfishtime-1.24/Makefile
+--- wmfishtime-1.24.orig/Makefile 2001-05-26 23:49:41.000000000 +0300
++++ wmfishtime-1.24/Makefile 2008-01-12 16:22:30.000000000 +0200
+@@ -2,11 +2,11 @@
+ DESTDIR =
+
+ # where to install this program
+-PREFIX = $(DESTDIR)/usr/X11R6
++PREFIX = $(DESTDIR)/usr
+
+ # no user serviceable parts below this line
+ # optimization cflags
+-CFLAGS = -O3 -Wall `gtk-config --cflags` ${EXTRA}
++CFLAGS += -Wall `pkg-config gtk+-2.0 --cflags` ${EXTRA}
+ # profiling cflags
+ # CFLAGS=-ansi -pedantic -Wall -pg -O3 `gtk-config --cflags` ${EXTRA} -DPRO
+ # test coverage cflags
+@@ -16,7 +16,7 @@
+ CC = gcc
+ SHELL = sh
+ OBJS = fishmon.o
+-LIBS = `gtk-config --libs | sed "s/-lgtk//g"`
++LIBS = `pkg-config gtk+-2.0 --libs` -lm -lX11
+ INSTALL = -m 755
+
+ all: wmfishtime
+@@ -30,4 +30,4 @@
+ # You're going to have to be root to do this!
+ install:
+ install $(INSTALL) wmfishtime $(PREFIX)/bin
+- install $(INSTALL) wmfishtime.1 $(PREFIX)/man/man1
++ install $(INSTALL) wmfishtime.1 $(PREFIX)/share/man/man1
diff --git a/x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch b/x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch
new file mode 100644
index 000000000000..a991cdab934b
--- /dev/null
+++ b/x11-plugins/wmfishtime/files/wmfishtime-1.24-no_display.patch
@@ -0,0 +1,19 @@
+--- fishmon.c.orig 2010-06-27 18:38:42.000000000 +0200
++++ fishmon.c 2010-06-27 18:40:56.000000000 +0200
+@@ -152,6 +152,8 @@
+
+ int main(int argc, char **argv)
+ {
++ /* This is needed to proper dockapp work on >=GTK+-2.18 */
++ setenv("GDK_NATIVE_WINDOWS", "1", 0);
+ int ch;
+ GdkEvent *event;
+ #ifdef PRO
+@@ -694,6 +696,7 @@
+ gdk_window_show(bm.win);
+
+ XSetWMHints(GDK_WINDOW_XDISPLAY(bm.win), win, &wmhints);
++ gdk_window_show(bm.iconwin);
+
+ #undef MASK
+ } /* make_new_fishmon_dockapp */