summaryrefslogtreecommitdiff
path: root/x11-plugins/wmfishtime/wmfishtime-1.24-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /x11-plugins/wmfishtime/wmfishtime-1.24-r3.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'x11-plugins/wmfishtime/wmfishtime-1.24-r3.ebuild')
-rw-r--r--x11-plugins/wmfishtime/wmfishtime-1.24-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/x11-plugins/wmfishtime/wmfishtime-1.24-r3.ebuild b/x11-plugins/wmfishtime/wmfishtime-1.24-r3.ebuild
new file mode 100644
index 000000000000..05564bfd1885
--- /dev/null
+++ b/x11-plugins/wmfishtime/wmfishtime-1.24-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit toolchain-funcs
+
+DESCRIPTION="A fun clock applet for your desktop featuring swimming fish"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
+SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${P}-gtk.patch
+ "${FILESDIR}"/${P}-no_display.patch )
+
+DOCS=( ALL_I_GET_IS_A_GRAY_BOX AUTHORS ChangeLog CODING README )
+
+src_prepare() {
+ default
+ sed -i -e "s/\$(CC)/& \$(LDFLAGS)/" Makefile || die #331891
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+ einstalldocs
+}