summaryrefslogtreecommitdiff
path: root/x11-plugins/wmhdplop/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmhdplop/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmhdplop/files')
-rw-r--r--x11-plugins/wmhdplop/files/wmhdplop-0.9.10-cflags.patch14
-rw-r--r--x11-plugins/wmhdplop/files/wmhdplop-0.9.10-sysmacros.patch11
-rw-r--r--x11-plugins/wmhdplop/files/wmhdplop-0.9.9-64bit.patch94
3 files changed, 119 insertions, 0 deletions
diff --git a/x11-plugins/wmhdplop/files/wmhdplop-0.9.10-cflags.patch b/x11-plugins/wmhdplop/files/wmhdplop-0.9.10-cflags.patch
new file mode 100644
index 000000000000..999379988317
--- /dev/null
+++ b/x11-plugins/wmhdplop/files/wmhdplop-0.9.10-cflags.patch
@@ -0,0 +1,14 @@
+diff -Naur wmhdplop-0.9.10.orig/configure.ac wmhdplop-0.9.10/configure.ac
+--- wmhdplop-0.9.10.orig/configure.ac 2016-11-24 16:18:21.000000000 +0100
++++ wmhdplop-0.9.10/configure.ac 2016-12-02 11:58:28.276017676 +0100
+@@ -19,10 +19,6 @@
+ AC_DEFINE(_GNU_SOURCE,[],[uses GNU extensions])
+
+
+-if test x$GCC = xyes; then
+- CFLAGS="-O3 -fomit-frame-pointer -ffast-math -Wall -W";
+-fi
+-
+ dnl check for X
+ AC_PATH_X
+ AC_PATH_XTRA
diff --git a/x11-plugins/wmhdplop/files/wmhdplop-0.9.10-sysmacros.patch b/x11-plugins/wmhdplop/files/wmhdplop-0.9.10-sysmacros.patch
new file mode 100644
index 000000000000..1346cd2e3641
--- /dev/null
+++ b/x11-plugins/wmhdplop/files/wmhdplop-0.9.10-sysmacros.patch
@@ -0,0 +1,11 @@
+diff -Naur wmhdplop-0.9.10.orig/devnames.c wmhdplop-0.9.10/devnames.c
+--- wmhdplop-0.9.10.orig/devnames.c 2016-11-24 15:49:55.000000000 +0100
++++ wmhdplop-0.9.10/devnames.c 2017-02-16 15:03:08.946447885 +0100
+@@ -4,6 +4,7 @@
+ #include <string.h>
+ #include <sys/types.h>
+ #include <sys/stat.h>
++#include <sys/sysmacros.h>
+ #include <unistd.h>
+ #include <linux/major.h>
+ #include <ctype.h>
diff --git a/x11-plugins/wmhdplop/files/wmhdplop-0.9.9-64bit.patch b/x11-plugins/wmhdplop/files/wmhdplop-0.9.9-64bit.patch
new file mode 100644
index 000000000000..13650e9bb7d9
--- /dev/null
+++ b/x11-plugins/wmhdplop/files/wmhdplop-0.9.9-64bit.patch
@@ -0,0 +1,94 @@
+diff -pudr wmhdplop-0.9.9/devnames.h wmhdplop-0.9.9-fixed/devnames.h
+--- wmhdplop-0.9.9/devnames.h 2004-04-07 01:14:01.000000000 +0200
++++ wmhdplop-0.9.9-fixed/devnames.h 2010-06-25 21:56:10.662190796 +0200
+@@ -9,7 +9,7 @@ typedef struct DiskList {
+ unsigned major, minor;
+ int hd_id, part_id; /* part_id = 0 for disks */
+ int enable_hddtemp;
+- int nr, nw, touched_r, touched_w;
++ long nr, nw, touched_r, touched_w;
+ struct DiskList *next;
+ } DiskList;
+
+diff -pudr wmhdplop-0.9.9/procstat.c wmhdplop-0.9.9-fixed/procstat.c
+--- wmhdplop-0.9.9/procstat.c 2007-04-20 11:12:16.000000000 +0200
++++ wmhdplop-0.9.9-fixed/procstat.c 2010-06-25 21:55:37.086191145 +0200
+@@ -8,7 +8,7 @@
+ static ProcStats ps;
+ int use_proc_diskstats;
+
+-void pstat_init(struct pstat *pst, int nslice, float update_interval) {
++void pstat_init(struct pstat *pst, long nslice, float update_interval) {
+ pst->nslice = nslice;
+ ALLOC_VEC(pst->slices, nslice);
+ pst->cur_slice = 0;
+@@ -17,7 +17,7 @@ void pstat_init(struct pstat *pst, int n
+ }
+
+ float pstat_current(struct pstat *pst) {
+- int idx = pst->cur_slice ? pst->cur_slice-1 : pst->nslice-1;
++ long idx = pst->cur_slice ? pst->cur_slice-1 : pst->nslice-1;
+ return pst->slices[idx]/pst->update_interval;
+ }
+
+@@ -101,13 +101,13 @@ void update_stats() {
+ if (!Prefs.debug_disk_rd) {
+ pstat_add(&ps.disk_read, nr);
+ } else {
+- static int cntr = 0; cntr+=(rand()%30) == 0 ? Prefs.debug_disk_rd : 0;
++ static long cntr = 0; cntr+=(rand()%30) == 0 ? Prefs.debug_disk_rd : 0;
+ pstat_add(&ps.disk_read, nr + cntr);
+ }
+ if (!Prefs.debug_disk_wr) {
+ pstat_add(&ps.disk_write, nw);
+ } else {
+- static int cntw = 0; cntw+=(rand()%30) == 0 ? Prefs.debug_disk_wr : 0;
++ static long cntw = 0; cntw+=(rand()%30) == 0 ? Prefs.debug_disk_wr : 0;
+ pstat_add(&ps.disk_write, nw + cntw);
+ }
+ readok = 2;
+@@ -121,7 +121,7 @@ void update_stats() {
+ pstat_add(&ps.swap_in, nr);
+ pstat_add(&ps.swap_out, nw);
+ } else {
+- static int cnt = 0; cnt+=Prefs.debug_swapio;
++ static long cnt = 0; cnt+=Prefs.debug_swapio;
+ pstat_add(&ps.swap_in, nr + cnt);
+ pstat_add(&ps.swap_out, nw + cnt);
+ }
+@@ -144,10 +144,10 @@ void init_stats(float update_interval) {
+ char s[512];
+ FILE *f;
+
+- pstat_init(&ps.swap_in, (int)(0.5/update_interval)+1, update_interval);
+- pstat_init(&ps.swap_out, (int)(0.5/update_interval)+1, update_interval);
+- pstat_init(&ps.disk_read, (int)(0.5/update_interval)+1, update_interval);
+- pstat_init(&ps.disk_write, (int)(0.5/update_interval)+1, update_interval);
++ pstat_init(&ps.swap_in, (long)(0.5/update_interval)+1, update_interval);
++ pstat_init(&ps.swap_out, (long)(0.5/update_interval)+1, update_interval);
++ pstat_init(&ps.disk_read, (long)(0.5/update_interval)+1, update_interval);
++ pstat_init(&ps.disk_write, (long)(0.5/update_interval)+1, update_interval);
+ f = fopen("/proc/swaps","r");
+ //if (!f) { perror("/proc/swaps"); exit(1); }
+ if (f) {
+diff -pudr wmhdplop-0.9.9/procstat.h wmhdplop-0.9.9-fixed/procstat.h
+--- wmhdplop-0.9.9/procstat.h 2004-03-14 12:07:15.000000000 +0100
++++ wmhdplop-0.9.9-fixed/procstat.h 2010-06-25 21:45:52.146334994 +0200
+@@ -4,7 +4,7 @@
+
+ struct pstat {
+ unsigned long total;
+- int nslice, cur_slice;
++ long nslice, cur_slice;
+ unsigned long *slices;
+ float update_interval;
+ };
+@@ -15,7 +15,7 @@ typedef struct {
+ struct pstat disk_read, disk_write;
+ } ProcStats;
+
+-void pstat_init(struct pstat *pst, int nslice, float update_interval);
++void pstat_init(struct pstat *pst, long nslice, float update_interval);
+ float pstat_current(struct pstat *pst);
+ void pstat_add(struct pstat *pst, unsigned long v);
+ void pstat_advance(struct pstat *pst);