summaryrefslogtreecommitdiff
path: root/x11-plugins/wmswallow
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-plugins/wmswallow
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-plugins/wmswallow')
-rw-r--r--x11-plugins/wmswallow/Manifest6
-rw-r--r--x11-plugins/wmswallow/files/wmswallow-0.6.1-format-security.patch16
-rw-r--r--x11-plugins/wmswallow/metadata.xml16
-rw-r--r--x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild37
4 files changed, 75 insertions, 0 deletions
diff --git a/x11-plugins/wmswallow/Manifest b/x11-plugins/wmswallow/Manifest
new file mode 100644
index 000000000000..c1b9fd1a5f5f
--- /dev/null
+++ b/x11-plugins/wmswallow/Manifest
@@ -0,0 +1,6 @@
+AUX wmswallow-0.6.1-format-security.patch 498 SHA256 192353599ed45738a1bbdf258c0c0b11925112b9a4d7a0ed0c3dbebdd100704c SHA512 9690c74b0f86ddc71ea4f7b190af8ec4d7634454a867654cae8cf2cc48560ab3182e8e3ce312db9eb6b858ef4ec0b9eb63f4c11e962cd17a3638d6d38fcf86cb WHIRLPOOL b905b9e643615ece9352f4936bf05f5368ea2f846722e76a0f0d1528da2351b76551509a442bb4a1772c8ef18f4e5a77f74c2f4674d2793c23c3fe184d545954
+DIST wmswallow.tar.Z 28567 SHA256 7d7a3dc64b89eeb388bb2f66815fc94cb551d0899f0e41d204f367109a2cda02 SHA512 24ef61a4084bda49afd6a7168600d99c60fe85daab6d16733fd208a905966433ca3d031a1d991676f3e73cb8a3a552c49fe69cfb4e1271e7c9a09d9247c21cdc WHIRLPOOL 1d6d6e19075b9a8daba03f99ef04357fc48bdb71e2373386f29a2636611ae20b56398b1871c8b163d069fbb4ee07c98cf1b27fd6bd5178a7756a011cd4d44be8
+EBUILD wmswallow-0.6.1-r1.ebuild 847 SHA256 2ebf627cd2ea45a63f1dd3e6028136e31a91f6f71907997680c8c8f656088c6e SHA512 ceb105cd6f980ebae86ebeed677572db5029c0c9d5ace9ba6022cf0c1bba57601db8f64b8942d3fbb750f7947f8295ab836660d6477b9aa9fd35298a337e431b WHIRLPOOL dcfb0207983025127d96fa66c181bddda5dbc9eb4b684ec3a7769c4de6c9540771240234e1966e5d35b7fc456419c56a4115d3f1fc4622d149b49b7ad61cfc5c
+MISC ChangeLog 2948 SHA256 e834ff9f6e3949bb665b2a1d5aed46a2aae29b4435cf4276f64276fbb2505cca SHA512 43091d650207e9266fd4c852a5c4752f5178d12e7d9c70e75ec0866d2466dd32bb1e7d3d82cb1126a1906282d2d58718ad6db65d73263e14e145159369e9a5e5 WHIRLPOOL bd50410475b0e6de55968a885f85076566fde49ea9badb5bd591c6571d6586495a88c82b65a746e9ba5a6ea816fd8a351ffc5600723afc4458e3a882bb1d0741
+MISC ChangeLog-2015 1857 SHA256 608e57ff6b553ab8db8976d27133a5c694cfd85a0c9c785371efc92d7a222be9 SHA512 a4390520a1a9bba86ffd5341b005dbedd314528083eb6a26d5dafe6c3d2fc3adb54460cfa1e451a113a06ea0c98a73ecd64c021e9b37cb45ed9d66ea3dfe85bf WHIRLPOOL 320ed75110a81c4034c08fbef6b08bd6dffaecae525b9d6ae4b6c817c9dd7aaa2701ffcfcdd973bedaa73cc9d3309fc165f12da2cb55ad9aef0f436a27b6cf28
+MISC metadata.xml 644 SHA256 89f43d37d2f6058417904a94c007a093187bdc46a9e24b72d7b5bfeb9c09514a SHA512 fc8f033978bedc4b9d080bc5d99dcd4200988b9751946fb855f182279a16913999c7372f6acb445818fb7fe336176dccd971b3709ee83a691966f6a35643de34 WHIRLPOOL 49180cb1dc28eeb3c69e95bae97edf5b2b8a1caa27ceb2c6d0f3de97b057ec388c1272e9540ec7ce2463ec23b6f3a33dde57e5985466d8abaaa4f55ece80fe96
diff --git a/x11-plugins/wmswallow/files/wmswallow-0.6.1-format-security.patch b/x11-plugins/wmswallow/files/wmswallow-0.6.1-format-security.patch
new file mode 100644
index 000000000000..7a2fe4cf1f36
--- /dev/null
+++ b/x11-plugins/wmswallow/files/wmswallow-0.6.1-format-security.patch
@@ -0,0 +1,16 @@
+--- wmswallow.c.orig 2015-04-01 17:12:29.420177608 +0200
++++ wmswallow.c 2015-04-01 17:13:14.947182921 +0200
+@@ -445,11 +445,11 @@
+ int printlist(FILE * stream, char * string, char **stringlist) {
+ int i=0;
+
+- fprintf(stream, string);
++ fprintf(stream, "%s", string);
+ if (stringlist!=NULL) {
+ while (stringlist[i]!=NULL) {
+ fprintf(stream, " §");
+- fprintf(stream, stringlist[i]);
++ fprintf(stream, "%s", stringlist[i]);
+ fprintf(stream, "§ ");
+ ++i;
+ }
diff --git a/x11-plugins/wmswallow/metadata.xml b/x11-plugins/wmswallow/metadata.xml
new file mode 100644
index 000000000000..7c9fa8c0177d
--- /dev/null
+++ b/x11-plugins/wmswallow/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>voyageur@gentoo.org</email>
+ <name>Bernard Cafarelli</name>
+</maintainer>
+
+<longdescription>
+wmswallow is a WindowMaker dock applet that makes any application dockable. You
+can define an action to be taken on a mouseclick if the window does not receive
+mouseclicks itself, and you can define the size and width of the swallowed
+window on the commandline. Applications may be started on the commandline and
+specified via name, class, or window-id.
+</longdescription>
+</pkgmetadata>
diff --git a/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild b/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..cb3f20011291
--- /dev/null
+++ b/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="A dock applet to make any application dockable"
+HOMEPAGE="http://burse.uni-hamburg.de/~friedel/software/wmswallow.html"
+SRC_URI="http://burse.uni-hamburg.de/~friedel/software/wmswallow/${PN}.tar.Z"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/wmswallow
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-format-security.patch
+ sed -e "s:\${OBJS} -o:\${OBJS} \${LDFLAGS} -o:" \
+ -e "/LIBS/s/-lXext/-lX11 \0/"\
+ -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" xfree
+}
+
+src_install() {
+ dobin wmswallow
+ dodoc CHANGELOG README todo
+}