summaryrefslogtreecommitdiff
path: root/x11-plugins
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-21 00:31:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-21 00:31:17 +0000
commitae832415103492f73a8351ed7a91cb596392d779 (patch)
tree50b8927d2d57e707e7e3402895a997ebbc349dda /x11-plugins
parent77684468238b8755c1aa3e72f3055f4e62fcf14c (diff)
gentoo auto-resync : 21:03:2025 - 00:31:16
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/Manifest.gzbin26130 -> 26127 bytes
-rw-r--r--x11-plugins/wmmand/Manifest2
-rw-r--r--x11-plugins/wmmand/files/wmmand-1.3.2-gcc-15.patch75
-rw-r--r--x11-plugins/wmmand/wmmand-1.3.2-r2.ebuild51
4 files changed, 128 insertions, 0 deletions
diff --git a/x11-plugins/Manifest.gz b/x11-plugins/Manifest.gz
index d96bc999863f..6ed4fb105736 100644
--- a/x11-plugins/Manifest.gz
+++ b/x11-plugins/Manifest.gz
Binary files differ
diff --git a/x11-plugins/wmmand/Manifest b/x11-plugins/wmmand/Manifest
index e2e3f277e3a5..64203c8bffd7 100644
--- a/x11-plugins/wmmand/Manifest
+++ b/x11-plugins/wmmand/Manifest
@@ -1,4 +1,6 @@
AUX wmmand-1.3.2-gcc-10.patch 1105 BLAKE2B 414c9e8cc721f610818b181148a2cdde079a3c5f1bc6ef1a07239f03c0aa5919b28675ee2b4d950b16cdfed2c0a057be90afe3a98d6040cbf706b9b4f6a30150 SHA512 95f548b151b92f5d302e746f073b2b3695ae0bdeaf8db065f29e2bc0d98925c30c17bfe2592759e1aed812306dbdc58991f3e4f0e4f3766e282cdc760cf842fb
+AUX wmmand-1.3.2-gcc-15.patch 2213 BLAKE2B 67a179d6fb2ccbda8cdf6e3190f71c01db9589580f5b9731208a97d74231ab176c2700ed33ad00bd4d3d678fe3c7e583a835b35f136d17df102b6501fa49908d SHA512 929d9c32434c122084438a3be1d6fe5eaf0b32a206cd128094ecee4c75dc3386a5e5a752879f46753511ff5cae19999417cfb439a46e3544b78504fbe26b9dd2
DIST wmMand-1.3.2.tar.bz2 41268 BLAKE2B 75eb252c162d2403e15a7e4df9ed79e0af5d9835c5c6ffc0208ac20f856f148a513f48460aedee7d26053867f464dd1b1c13d3fabbb2151513eab6102dfaefe0 SHA512 03a06c114371bf98037ac8859010fcbd20ec675fdd563b655c1be58a384a48f59d36bcb795759e45dba798af765ae179df1bf591d2ee7fe245069af06c8b5587
EBUILD wmmand-1.3.2-r1.ebuild 870 BLAKE2B 8f418b271be02573db8f5bfd82103b80f307720c831fcc960f2a44f070bc267b78f4b38e64f6e2b4578643989530944844f941140ab1eba063075976bc4f288b SHA512 2d027a756a75d0db5e06c0d6b05e7ef9ee7abbf1eb72ff3cb5a44a4811aa4dae8c3c4120fbee232c9a3798125e45e49d4f9ac478b13f6a5f4f735a2aa7bb047c
+EBUILD wmmand-1.3.2-r2.ebuild 952 BLAKE2B f9b277e66646225a618402b97be3aed284345d3cef4018d86a9f580b6a1f2568df9397cc52df3f8e30ae7e9a98e48950cea1c0c11b27410d0537b2f6175b5981 SHA512 0e83e76cd2b51be7945f273f1d4999e816bfe6eb742b1c653b45c339eab493e9d4c6da392d5a7147af011f55730f133265e90165f2c0b215a04cb08a39325d78
MISC metadata.xml 329 BLAKE2B e530d6c6ba018a8a4a61b2f78c947e9d2b1a1831cccf3785b7ce624ff1bb5b1a59ee422e600aa8f82b6409a68cdc223c0f763cb2a606ed22255a50951145955c SHA512 ef5b6925e57fdb1c9c5be591c237f48f3b30b1a66c96b50577b994b9d6a95bfa98fb92cb101f8c1b3f00500280764c906886bba6beef3119e8634ea61dfe5120
diff --git a/x11-plugins/wmmand/files/wmmand-1.3.2-gcc-15.patch b/x11-plugins/wmmand/files/wmmand-1.3.2-gcc-15.patch
new file mode 100644
index 000000000000..c07569fbdbdb
--- /dev/null
+++ b/x11-plugins/wmmand/files/wmmand-1.3.2-gcc-15.patch
@@ -0,0 +1,75 @@
+Port to C23, minimal fix to enable rudimentary test
+Correct function declaration, use correct type for Window:
+X expects that it's value everywhere, with pointer already inside
+Return 0 when asked for help, not default 1
+https://bugs.gentoo.org/943913
+https://bugs.gentoo.org/880965
+--- a/wmgeneral/wmgeneral.c
++++ b/wmgeneral/wmgeneral.c
+@@ -46,7 +46,7 @@
+ char *Geometry = "";
+ Pixmap pixmask;
+ Display *display;
+-Window *Root;
++Window Root;
+ int d_depth;
+ GC NormalGC;
+ XpmIcon wmgen;
+--- a/wmgeneral/wmgeneral.h
++++ b/wmgeneral/wmgeneral.h
+@@ -29,7 +29,7 @@
+ /*******************/
+
+ extern Display *display;
+-extern Window *Root;
++extern Window Root;
+ extern int d_depth;
+ extern GC NormalGC;
+ extern XpmIcon wmgen;
+--- a/wmMand/wmMand.c
++++ b/wmMand/wmMand.c
+@@ -124,8 +124,10 @@
+ int maxIterations;
+ LargeViewer largeViewProg = LARGEVIEWER_IM;
+
+-int WriteGIF();
+-
++typedef unsigned char byte;
++int WriteGIF(FILE *fp, byte *pic, int ptype, int w, int h, byte *rmap,
++ byte *gmap, byte *bmap, int numcols, int colorstyle,
++ char *comment);
+
+ /*
+ * main
+--- a/wmMand/xvgifwr.c
++++ b/wmMand/xvgifwr.c
+@@ -78,14 +78,9 @@
+
+
+ /*************************************************************/
+-int WriteGIF(fp, pic, ptype, w, h, rmap, gmap, bmap, numcols, colorstyle,
+- comment)
+- FILE *fp;
+- byte *pic;
+- int ptype, w,h;
+- byte *rmap, *gmap, *bmap;
+- int numcols, colorstyle;
+- char *comment;
++int WriteGIF(FILE *fp, byte *pic, int ptype, int w, int h, byte *rmap,
++ byte *gmap, byte *bmap, int numcols, int colorstyle,
++ char *comment)
+ {
+ int RWidth, RHeight;
+ int LeftOfs, TopOfs;
+--- a/wmMand/wmMand.c
++++ b/wmMand/wmMand.c
+@@ -392,6 +392,9 @@
+ printf("\t\E[1m-d, --delayzoom <number>\E[m\n\t\tset delay for autozooming with mouse (default %d, larger values give longer delay). Dependent on CPU cycle availability\n", autoZoomDelay);
+ printf("\t\E[1m-x, --xv\E[m\n\t\tuse xv to display large image instead of ImageMagic's display program\n");
+ printf("\t\E[1m-h, --help\E[m\n\t\tdisplay help screen\n");
++ if (!strcmp(argv[i], "--help") || !strcmp(argv[i] , "-h")) {
++ exit(0);
++ }
+ exit(1);
+ }
+ }
diff --git a/x11-plugins/wmmand/wmmand-1.3.2-r2.ebuild b/x11-plugins/wmmand/wmmand-1.3.2-r2.ebuild
new file mode 100644
index 000000000000..c888c49702bc
--- /dev/null
+++ b/x11-plugins/wmmand/wmmand-1.3.2-r2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit desktop toolchain-funcs edo
+
+MY_P="wmMand-${PV}"
+
+DESCRIPTION="a dockable mandelbrot browser"
+HOMEPAGE="https://sourceforge.net/projects/wmmand/"
+SRC_URI="https://downloads.sourceforge.net/${PN}/${MY_P}.tar.bz2"
+S="${WORKDIR}/${MY_P}/wmMand"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+
+DOCS=( ../{BUGS,changelog,TODO} )
+
+src_prepare() {
+ default
+ gunzip wmMand.6.gz || die
+
+ pushd "${WORKDIR}"/${MY_P} || die
+ eapply "${FILESDIR}"/${P}-gcc-10.patch
+ eapply "${FILESDIR}"/${P}-gcc-15.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
+ SYSTEM="${LDFLAGS}" \
+ INCDIR="" LIBDIR=""
+}
+
+src_test() {
+ edo "${S}"/wmMand -h
+}
+
+src_install() {
+ dobin wmMand
+ doman wmMand.6
+ doicon wmMand.png
+ einstalldocs
+}