summaryrefslogtreecommitdiff
path: root/x11-terms/guake/guake-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-03 10:28:17 +0000
commitd99093fb4bb5652015c06274d64083daa2439e4f (patch)
treecf61513204d97974179580065e85df5c8009087c /x11-terms/guake/guake-9999.ebuild
parent463397cf1e064185110fe57c568d73f99a06f5d1 (diff)
gentoo resync : 03.03.2021
Diffstat (limited to 'x11-terms/guake/guake-9999.ebuild')
-rw-r--r--x11-terms/guake/guake-9999.ebuild28
1 files changed, 16 insertions, 12 deletions
diff --git a/x11-terms/guake/guake-9999.ebuild b/x11-terms/guake/guake-9999.ebuild
index 7d3392905944..51743bb8c8f5 100644
--- a/x11-terms/guake/guake-9999.ebuild
+++ b/x11-terms/guake/guake-9999.ebuild
@@ -1,21 +1,28 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_7 )
+
+PYTHON_COMPAT=( python3_{7..9} )
DISTUTILS_SINGLE_IMPL=1
-inherit distutils-r1 git-r3 gnome2-utils xdg-utils
+inherit distutils-r1 gnome2-utils xdg-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/Guake/guake.git"
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
DESCRIPTION="Drop-down terminal for GNOME"
HOMEPAGE="
https://github.com/Guake/guake/
https://pypi.org/project/guake/"
-EGIT_REPO_URI="https://github.com/Guake/guake.git"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
IUSE="utempter"
RDEPEND="
@@ -30,14 +37,11 @@ RDEPEND="
x11-libs/libnotify[introspection]
x11-libs/libwnck:3[introspection]
x11-libs/vte:2.91[introspection]
- utempter? ( sys-libs/libutempter )
-"
-DEPEND="
- ${RDEPEND}
+ utempter? ( sys-libs/libutempter )"
+DEPEND="${RDEPEND}"
+BDEPEND="
gnome-base/gsettings-desktop-schemas
- sys-devel/gettext
- sys-devel/make
-"
+ sys-devel/gettext"
PATCHES=(
"${FILESDIR}"/${PN}-3.3.2-paths.patch