summaryrefslogtreecommitdiff
path: root/x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild')
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild
new file mode 100644
index 000000000000..4bf3e29efd4b
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-9999.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit git-r3
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+
+LICENSE="GPL-3"
+SLOT="0"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+}