summaryrefslogtreecommitdiff
path: root/x11-terms/kitty-terminfo/kitty-terminfo-0.26.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-29 10:46:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-29 10:46:12 +0100
commitd3fc35858ba4bc0c8038a8c536246b00fe648358 (patch)
tree416e79067bd12fc0b43e12f1b73ee15a62b8a5bf /x11-terms/kitty-terminfo/kitty-terminfo-0.26.0.ebuild
parent2512faa12f58e69a2f3e27e13e10fd0aef3ab384 (diff)
gentoo auto-resync : 29:08:2022 - 10:46:12
Diffstat (limited to 'x11-terms/kitty-terminfo/kitty-terminfo-0.26.0.ebuild')
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.26.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.26.0.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.26.0.ebuild
new file mode 100644
index 000000000000..35ff98034a87
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.26.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}