summaryrefslogtreecommitdiff
path: root/x11-terms/kitty-terminfo/kitty-terminfo-0.26.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-22 17:28:08 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-22 17:28:08 +0100
commitd79ab35b7ac170babebe8bc151fe5d037c16285c (patch)
treec774a4913f32e952079ae36fc6afd2dad747837f /x11-terms/kitty-terminfo/kitty-terminfo-0.26.3.ebuild
parent992aa50a54a56c9e705ca4e85d809ec8989d74a2 (diff)
gentoo auto-resync : 22:09:2022 - 17:28:08
Diffstat (limited to 'x11-terms/kitty-terminfo/kitty-terminfo-0.26.3.ebuild')
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.26.3.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.26.3.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.26.3.ebuild
new file mode 100644
index 000000000000..35ff98034a87
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.26.3.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}