summaryrefslogtreecommitdiff
path: root/x11-terms/lilyterm/lilyterm-99999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /x11-terms/lilyterm/lilyterm-99999.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'x11-terms/lilyterm/lilyterm-99999.ebuild')
-rw-r--r--x11-terms/lilyterm/lilyterm-99999.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-terms/lilyterm/lilyterm-99999.ebuild b/x11-terms/lilyterm/lilyterm-99999.ebuild
new file mode 100644
index 000000000000..21280cce5b43
--- /dev/null
+++ b/x11-terms/lilyterm/lilyterm-99999.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools git-r3
+
+DESCRIPTION="a terminal emulator based off of libvte that aims to be fast and lightweight"
+HOMEPAGE="https://lilyterm.luna.com.tw"
+EGIT_REPO_URI="https://github.com/Tetralet/LilyTerm"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS=""
+
+RDEPEND="
+ x11-libs/vte:2.91
+"
+DEPEND="
+ ${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog README TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-99999-autogen.patch
+)
+
+src_prepare() {
+ default
+
+ ./autogen.sh || die
+ eautoreconf
+}