summaryrefslogtreecommitdiff
path: root/x11-terms/qterminal/qterminal-1.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-18 05:54:20 +0100
commit5a1fb66df455454109e1de61d38b48f509dc68b8 (patch)
tree0213f12db1b0138bffda43d11208c5d701967638 /x11-terms/qterminal/qterminal-1.3.0.ebuild
parent3a8423ee2874c2fd96358b28af08d38d83e9bdc0 (diff)
gentoo auto-resync : 18:04:2023 - 05:54:20
Diffstat (limited to 'x11-terms/qterminal/qterminal-1.3.0.ebuild')
-rw-r--r--x11-terms/qterminal/qterminal-1.3.0.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-terms/qterminal/qterminal-1.3.0.ebuild b/x11-terms/qterminal/qterminal-1.3.0.ebuild
new file mode 100644
index 000000000000..7e969e772422
--- /dev/null
+++ b/x11-terms/qterminal/qterminal-1.3.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake xdg-utils
+
+DESCRIPTION="Qt-based multitab terminal emulator"
+HOMEPAGE="https://lxqt-project.org/"
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="GPL-2 GPL-2+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND=">=dev-util/lxqt-build-tools-0.13.0"
+DEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ >=dev-qt/qtx11extras-5.15:5
+ x11-libs/libX11
+ ~x11-libs/qtermwidget-${PV}:=
+ test? ( dev-qt/qttest:5 )
+"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}