summaryrefslogtreecommitdiff
path: root/x11-terms/root-tail
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-31 16:00:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-31 16:00:27 +0000
commit1db00cc6e94b90c08090bb5b8c406622946c4ae5 (patch)
treec34bf820c2809fb7e08ed5564df2a25cf759516f /x11-terms/root-tail
parent693cc9b6e847a01c1bb692153021aaf9fb0fab25 (diff)
gentoo resync 31.01.2019
Diffstat (limited to 'x11-terms/root-tail')
-rw-r--r--x11-terms/root-tail/Manifest1
-rw-r--r--x11-terms/root-tail/root-tail-1.2-r4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/x11-terms/root-tail/Manifest b/x11-terms/root-tail/Manifest
index aa5441a22687..7a2464ee7ec6 100644
--- a/x11-terms/root-tail/Manifest
+++ b/x11-terms/root-tail/Manifest
@@ -1,4 +1,5 @@
AUX root-tail-1.2-kde.patch 3188 BLAKE2B 122e2ade46725c9e1dacaf5e68f283b3efe2c968407e48d7ee0567e10d5d360f479588ac1b9f6da74a5d0fec52e83ac51ddc6789d8b560c43a83aba5b1ba5ac4 SHA512 f99c8cd04664d7e1afe21854d2ba9114387c55fa89268aca7cbeb88ecfeedad26529bdfd2b52dbe88d74959f4943571bda1f518fb41d8827f04f25e250bc7fb7
DIST root-tail-1.2.tar.gz 20805 BLAKE2B 29891f0bbedc18d6b4e6e726234d7abaf107fa96b3da3a38a5a3aa91edd00403ae52166491cd5ec59f903b12c0edcddc92a3576db3127a837ae9ac3480823c40 SHA512 9e0b046d3e22ad8e85baa356ae8850885759e28624840901465c88c5791595db89da8d7908446cfa52cef180d2ae5a6d3857310679dc37545b6a9cabdd1d3e10
EBUILD root-tail-1.2-r3.ebuild 1019 BLAKE2B 774c76402cf892e301ab37ce1239ae79559f1fbaebdbe42ba7fa3c33027df3b989fbe7ec61cfceffaff4f32b3c2dae9a5f81bbec4eb8601cbb03b48b6efc8dcb SHA512 4651e93ec7dc145b8b980eb727b2af7b9eca70070d8b2eb30d37b4d9a6462bd82ad092ff8ee7e4ebe40162448556a52db24fe5eb181c88d008ccf84619895e59
+EBUILD root-tail-1.2-r4.ebuild 965 BLAKE2B f3b8922dbc06b7b30b6b90a0733f09b6da019b94f4934cbf79eb28d87e3800d3b2e8272e686ca0bab9ba19f07a0525f9949e6781a99f4cda4c45b191208ff944 SHA512 2ae21cd0f0b1ea6c4a3ef91777b35c5dfb50cfae63200bbb56558782864fcbaa2fc060e5467a8280ae82247401135204ba9c026fda20b9799445e0f6fb286e9a
MISC metadata.xml 166 BLAKE2B c254f1fb642881aba57637be14fb0a89b10384f91a128feaec3a8c870d76efc2cbacb92caccc0dee2dd19a5ac5eaf8643080dafa05c4e2ac96a68568927e5afd SHA512 a56648c974a1d14dd4c18237532773c72057a13ab90c58b5da04f185e3c12a8bd8d5c21fb06053507f31766291a82dc7d87b34cd65fd94cfe2af7295c813ef84
diff --git a/x11-terms/root-tail/root-tail-1.2-r4.ebuild b/x11-terms/root-tail/root-tail-1.2-r4.ebuild
new file mode 100644
index 000000000000..465304ebd74e
--- /dev/null
+++ b/x11-terms/root-tail/root-tail-1.2-r4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic toolchain-funcs
+
+DESCRIPTION="Terminal to display (multiple) log files on the root window"
+HOMEPAGE="http://oldhome.schmorp.de/marc/root-tail.html"
+SRC_URI="http://oldhome.schmorp.de/marc/data/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="kde debug"
+
+RDEPEND="x11-libs/libXext
+ x11-libs/libX11"
+DEPEND="x11-misc/imake
+ app-text/rman
+ x11-base/xorg-proto
+ x11-libs/libX11
+ x11-misc/gccmakedep"
+
+src_prepare() {
+ use kde && eapply "${FILESDIR}"/${P}-kde.patch
+ default
+}
+
+src_configure() {
+ xmkmf -a
+}
+
+src_compile() {
+ sed -i 's:/usr/X11R6/bin:/usr/bin:' Makefile || die "sed Makefile failed"
+ use debug && append-flags -DDEBUG
+ emake \
+ CC=$(tc-getCC) \
+ CCOPTIONS="${CFLAGS}" \
+ EXTRA_LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install install.man
+ dodoc Changes README
+}