summaryrefslogtreecommitdiff
path: root/x11-terms/sakura/sakura-3.8.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /x11-terms/sakura/sakura-3.8.3.ebuild
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'x11-terms/sakura/sakura-3.8.3.ebuild')
-rw-r--r--x11-terms/sakura/sakura-3.8.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-terms/sakura/sakura-3.8.3.ebuild b/x11-terms/sakura/sakura-3.8.3.ebuild
new file mode 100644
index 000000000000..bb84f11c518d
--- /dev/null
+++ b/x11-terms/sakura/sakura-3.8.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+DESCRIPTION="GTK/VTE based terminal emulator"
+HOMEPAGE="https://www.pleyades.net/david/projects/sakura"
+SRC_URI="https://launchpad.net/sakura/trunk/${PV}/+download/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-linux"
+
+RDEPEND="
+ dev-libs/glib:2
+ x11-libs/gtk+:3[X]
+ x11-libs/pango
+ x11-libs/vte:2.91"
+DEPEND="
+ ${RDEPEND}
+ x11-base/xorg-proto
+ x11-libs/libX11"
+BDEPEND="
+ sys-devel/gettext
+ virtual/perl-podlators"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-gentoo.patch
+ "${FILESDIR}"/${P}-opacity.patch
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ if [[ -v LINGUAS ]]; then
+ local lingua
+ for lingua in po/*.po; do
+ lingua=${lingua#*/}
+ lingua=${lingua%.*}
+ has ${lingua} ${LINGUAS} || rm po/${lingua}.po || die
+ done
+ fi
+}