summaryrefslogtreecommitdiff
path: root/x11-terms/terminology
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-02 08:55:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-02 08:55:38 +0000
commit5a1e5a6812ca9c9555657cce48fe09d2ffa44401 (patch)
tree5c040bbee9184b24f26b05031a2448e62f6df38a /x11-terms/terminology
parent2c4066122b66fa1eb3e37846f9a6e14529a553d8 (diff)
gentoo auto-resync : 02:12:2022 - 08:55:37
Diffstat (limited to 'x11-terms/terminology')
-rw-r--r--x11-terms/terminology/Manifest2
-rw-r--r--x11-terms/terminology/terminology-1.13.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/x11-terms/terminology/Manifest b/x11-terms/terminology/Manifest
index c9e3154b9080..892966feb054 100644
--- a/x11-terms/terminology/Manifest
+++ b/x11-terms/terminology/Manifest
@@ -1,3 +1,5 @@
DIST terminology-1.12.1.tar.xz 2722144 BLAKE2B ce6eea2fd6efe8a4a6d654f8e7899336b3bb7a1d2f1728c2ac2f1b367972c8b222e665309e2b704dd1f3bb774784d218789bcd8134348893a265c0e50fa855d9 SHA512 036f1e516d5f9c44185fc417266022bb4a3c34839451b2bd7ab64c9610e71cd1690faee014cf8364ceac12261cb9b57501446a3e6e58ac13f98f11064498a43b
+DIST terminology-1.13.0.tar.xz 2765572 BLAKE2B e918feeb848c9373f38a41a99893210e62fd47206d4c9557a0afcd65a25c978671ddcadbdf955b7514754bc6a47dd3c36ff867b14d3cbda48039b8ac6e8502b8 SHA512 95e8f8bdf51e63b07f7bc5bf1aead98b9bd34c58e13df29d4726f1a81e560d071119035aa94218632e840bc5146c3bc475641934eebd6c7e37e00bed94451beb
EBUILD terminology-1.12.1-r1.ebuild 1115 BLAKE2B 2f66a03a7fc21fc8894c94f9e1a55a3474324f2e5bf238ace58e01c6111c342681844d26efb5a83ba34304af484f6a63aabcbe57af5e161574c761260ad3f28a SHA512 c8190862a7569dc949568de7e670cf1a932648dffe15c5363a74b9f82a23a90af846be9160c16b586c181fe1d93217e8c876549796801d4f41b17ce14942de3a
+EBUILD terminology-1.13.0.ebuild 1117 BLAKE2B bcdf250c1925d566ddd4e53419386274a01bd97a5cd9f733b8455f6e3b778774dd4c2f6292418ceb38e95d6762a6cdc1f16d1410f7f179bb684094bf92d3b68b SHA512 e245d9d0f96ea24109d1f368fa5d59cb4bd2f658672ad1a7035ed0d0a52d074652e4a9f7faa8af959a27553ef36472e70f60c1b9b2745779785bb3ab0d3bda76
MISC metadata.xml 336 BLAKE2B 6f8e4a99a9941e3a9dba25832ae43998f1cc27e85c4535494f6762f99e915aa3be299cefdd9a8e9fcd1e5d934c87de826c64c72f1e74f4a49f57aa76de73595f SHA512 12190b1f38b235ba164b13cb7bac3f24fafc65a001c9cc5d7f24fbefed5ed5cb411a563ff57a54db722a3a79b9030d8eeaaaaafa4df79b0e2758393dc9332fa0
diff --git a/x11-terms/terminology/terminology-1.13.0.ebuild b/x11-terms/terminology/terminology-1.13.0.ebuild
new file mode 100644
index 000000000000..109a118568bb
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.13.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit meson python-any-r1 xdg
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/terminology/${P}.tar.xz https://downloads.terminolo.gy/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="extras nls"
+
+RDEPEND="|| ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ app-arch/lz4
+ >=dev-libs/efl-1.26.1[eet,fontconfig]"
+DEPEND="${RDEPEND}"
+BDEPEND="${PYTHON_DEPS}
+ virtual/libintl
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ # Fix python shebangs for python-exec[-native-symlinks], #766081
+ local shebangs=($(grep -rl "#!/usr/bin/env python3" || die))
+ python_fix_shebang -q ${shebangs[*]}
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use nls)
+ $(meson_use extras tests)
+ )
+
+ meson_src_configure
+}