summaryrefslogtreecommitdiff
path: root/x11-terms/xfce4-terminal
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-12-27 06:30:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-12-27 06:30:35 +0000
commit721e451ec418e1712f6962404e111f0ebd487389 (patch)
treeaab5b35236af464349c2522312c63b664273465c /x11-terms/xfce4-terminal
parente80134587e8d959a88dba7dd3784895372e205c8 (diff)
gentoo auto-resync : 27:12:2024 - 06:30:34
Diffstat (limited to 'x11-terms/xfce4-terminal')
-rw-r--r--x11-terms/xfce4-terminal/Manifest2
-rw-r--r--x11-terms/xfce4-terminal/xfce4-terminal-1.1.4.ebuild58
2 files changed, 60 insertions, 0 deletions
diff --git a/x11-terms/xfce4-terminal/Manifest b/x11-terms/xfce4-terminal/Manifest
index aedad3656123..2049388d4c81 100644
--- a/x11-terms/xfce4-terminal/Manifest
+++ b/x11-terms/xfce4-terminal/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-terminal-1.1.3.tar.bz2 1042732 BLAKE2B e4cdd24a19525f6da16483e1db7d80995396600d80b857e56c9859c25c3a54ba324205ab4938e3cea66da18495c8c32b8cc85ad4583593e289246ea3dbd34b74 SHA512 12d489099851b281d3ac83a4d9b2f459ed8442899823edba36055a0aa731d1821686f400d5d370833077b0ccf930cb3dfdf5800af58dd2339377dd7e902210b9
+DIST xfce4-terminal-1.1.4.tar.bz2 1498643 BLAKE2B 290a765b8873b54f799166fa28e4ff92d712a7b90cbd16479ea3aa1eb93782f8f63b7a45c0a6ec62fba6b1cebfa9d7a80ffd8ab9b6f482c14a83a842167645eb SHA512 c2a749f75142690f188d1f66a63573c612bb47db42f1933d63cfd8026ac0a66067112d92ff52f9ce7dfb735f7f6ea1ac55d34077be0341e7848dd7daffc101a9
EBUILD xfce4-terminal-1.1.3.ebuild 1271 BLAKE2B 0f3812612acad708699779b241b6e869399e55f622c45ef310d16f01869c51a22d301e2ec6cb192647b159e4cae26ebe638c55a72c9a53a1083104bad5b1c916 SHA512 1191127c91711a447e774288d7cf0d29533c828ed179a0f7200df44275194ef01eb173dc948e5dab747a7a8de5cf8769ba08769f586dab24e8800c929e75412c
+EBUILD xfce4-terminal-1.1.4.ebuild 1267 BLAKE2B e004220b99d1f76c9e0647cf9942574c0881df7d29ae1a6f252bf9f3ac2c6df9a4dc51a706213f54be6410db5bbc1840fe1f25c46b04653af463adeff6b29f76 SHA512 bf832487de297e0646461f42209e723f7eaff8cddc128d921dfa32cf655e827ea7dcff1e2c4a9311596ffac03c1763943621825686fa2d9d9a3cfd70f40ca402
MISC metadata.xml 372 BLAKE2B bb4bcd3652bb3bbaee272af26e6b07b5279167c165574cfcbaa1c23d8b9786cc79972325893fc563aac5ae1eef257ebe4807199497a02c147515af68b80e27a2 SHA512 722c99f01658541a9d1df513ffa218ac36897644e771d8b439bf6b2c38e241304c0a43c94115ed95f367ba6e3a8606bee2c63ef8c1ef9841f08b9f06977751c7
diff --git a/x11-terms/xfce4-terminal/xfce4-terminal-1.1.4.ebuild b/x11-terms/xfce4-terminal/xfce4-terminal-1.1.4.ebuild
new file mode 100644
index 000000000000..7efc916cb93c
--- /dev/null
+++ b/x11-terms/xfce4-terminal/xfce4-terminal-1.1.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A terminal emulator for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/apps/terminal/start
+ https://gitlab.xfce.org/apps/xfce4-terminal/
+"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/$(ver_cut 1-2)/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="utempter wayland X"
+REQUIRED_USE="|| ( wayland X )"
+
+RDEPEND="
+ >=dev-libs/glib-2.44.0:2
+ >=dev-libs/libpcre2-10.00:=
+ >=x11-libs/gtk+-3.22.0:3[wayland?,X?]
+ >=x11-libs/vte-0.51.3:2.91
+ >=xfce-base/libxfce4ui-4.17.5:=[gtk3(+)]
+ >=xfce-base/xfconf-4.16.0:=
+ utempter? ( sys-libs/libutempter:= )
+ wayland? ( >=gui-libs/gtk-layer-shell-0.7.0 )
+ X? ( >=x11-libs/libX11-1.6.7 )
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ dev-libs/libxml2
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_with utempter)
+ $(use_enable wayland)
+ $(use_enable wayland gtk-layer-shell)
+ $(use_enable X x11)
+ )
+
+ econf "${myconf[@]}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}