summaryrefslogtreecommitdiff
path: root/x11-terms/yeahconsole/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-20 02:17:30 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-20 02:17:30 +0000
commit8dd17625671faf6a47abf31d4c96a1e20d764ba5 (patch)
tree6dd5062cd293d1c2fc5af1f89cd548c7b3a62f3c /x11-terms/yeahconsole/files
parentd4725f7e03f4d243d29d408f4b9de39459e00d4c (diff)
gentoo auto-resync : 20:02:2023 - 02:17:29
Diffstat (limited to 'x11-terms/yeahconsole/files')
-rw-r--r--x11-terms/yeahconsole/files/yeahconsole-0.3.4-C99-decls.patch11
-rw-r--r--x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch45
2 files changed, 39 insertions, 17 deletions
diff --git a/x11-terms/yeahconsole/files/yeahconsole-0.3.4-C99-decls.patch b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-C99-decls.patch
new file mode 100644
index 000000000000..a6e5fb5f64c3
--- /dev/null
+++ b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-C99-decls.patch
@@ -0,0 +1,11 @@
+--- a/yeahconsole.c
++++ b/yeahconsole.c
+@@ -340,7 +340,7 @@
+ XMapWindow(dpy, win);
+ }
+
+-void init_xterm(move)
++void init_xterm(int move)
+ {
+ XEvent ev;
+ long dummy;
diff --git a/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
index 0075c433292b..1d1a403e6b12 100644
--- a/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
+++ b/x11-terms/yeahconsole/files/yeahconsole-0.3.4-make.patch
@@ -1,30 +1,41 @@
---- a/Makefile 2006-01-14 16:54:05.000000000 +0100
-+++ b/Makefile 2009-02-26 16:18:25.000000000 +0100
-@@ -1,6 +1,4 @@
+--- a/Makefile
++++ b/Makefile
+@@ -1,30 +1,21 @@
TARGET = yeahconsole
-CC = gcc
-#CC = cc
INSTALL = install
- PREFIX = /usr/local
-@@ -8,17 +6,16 @@
- LIBS = -lX11
- INCLUDES = -I/usr/X11R6/include
- LIB_DIRS = -L/usr/X11R6/lib
--FLAGS = -Os -Wall
-+FLAGS = -Wall $(CFLAGS)
-
- OBJECTS := yeahconsole.o
- SOURCES := yeahconsole.c
+-PREFIX = /usr/local
++PREFIX = $(EPREFIX)/usr
- $(TARGET): $(OBJECTS)
+-LIBS = -lX11
+-INCLUDES = -I/usr/X11R6/include
+-LIB_DIRS = -L/usr/X11R6/lib
+-FLAGS = -Os -Wall
+-
+-OBJECTS := yeahconsole.o
+-SOURCES := yeahconsole.c
+-
+-$(TARGET): $(OBJECTS)
- $(CC) $(DEFINES) $(INCLUDES) $(LIB_DIRS) $(LIBS) -o $@ $<
- strip $@
-+ $(CC) $(FLAGS) $(LDFLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -o $@ $< $(LIBS)
++PKG_CONFIG ?= pkg-config
++CFLAGS += -Wall
++CPPFLAGS += $(shell $(PKG_CONFIG) --cflags x11)
++LDLIBS += $(shell $(PKG_CONFIG) --libs x11)
- $(OBJECTS): $(SOURCES)
+-$(OBJECTS): $(SOURCES)
- $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
-+ $(CC) $(FLAGS) $(DEFINES) $(INCLUDES) $(LIB_DIRS) -c -o $@ $<
++all: $(TARGET)
clean:
rm -rf $(TARGET) $(OBJECTS)
+
+ install: $(TARGET) $(MAN)
+- $(INSTALL) -o root -g root -m 0755 $(TARGET) $(PREFIX)/bin
++ $(INSTALL) -d $(DESTDIR)$(PREFIX)/bin
++ $(INSTALL) -o root -g root -m 0755 $(TARGET) $(DESTDIR)$(PREFIX)/bin
+
+
+ uninstall: