summaryrefslogtreecommitdiff
path: root/x11-terms/zutty
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-27 06:06:27 +0000
commit8d5dbd847cbc704a6a06405856e94b461011afe3 (patch)
tree4d26462d027b14926335894749d2e01d982234d0 /x11-terms/zutty
parent5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (diff)
gentoo resync : 27.03.2021
Diffstat (limited to 'x11-terms/zutty')
-rw-r--r--x11-terms/zutty/Manifest3
-rw-r--r--x11-terms/zutty/metadata.xml26
-rw-r--r--x11-terms/zutty/zutty-0.8.ebuild29
3 files changed, 58 insertions, 0 deletions
diff --git a/x11-terms/zutty/Manifest b/x11-terms/zutty/Manifest
new file mode 100644
index 000000000000..e672e647ebd3
--- /dev/null
+++ b/x11-terms/zutty/Manifest
@@ -0,0 +1,3 @@
+DIST zutty-0.8.tar.gz 307235 BLAKE2B 897fea3735785ba1e8c811adbc90b96598c04f3ec19d9d3027745e5b9d3c1d21c55343b9409e48327139545e2675346be90d84af422d3ce97b1737cc287bb96b SHA512 75c5637fe8f0c8aff41e394a05f304f56bf03faf1dfa78807ca930a722536a93f54012f051f411b4e8ff478dd991f5b8ca1285fcd674879eac568c8971004317
+EBUILD zutty-0.8.ebuild 722 BLAKE2B 51455d9434b2c46a3020461efad6a75951890a5afb4cd16cb2902c30cdf06945b7210ebdeccb7e7124802a8a52d9fb7e75a4ee09343e01710e46bb9ae57fdb9e SHA512 8303765c956016ebc667149189a5b8a1b257a4db347b382a22a2e5b932837cf265592562c531b65fca7b6c8f830df79cfb703ebd7b856c93b7edf6b5fae930bb
+MISC metadata.xml 1156 BLAKE2B 86e49541468db22123cd56f6aee08e61e6e79daddb817a11bf549b7c50cbcf5ed165316772c726caf7aaa0dc1321753ec3cd36eb25d88fad4216520827ad59e2 SHA512 3caa4dbda104f1fc1ab8326e40de573d2d8ba445c3a1002dd5c24d64d2bba9c5808addae2508d267497d80d90cd0cf285244a9874f9a31f62175f3c77adfadc5
diff --git a/x11-terms/zutty/metadata.xml b/x11-terms/zutty/metadata.xml
new file mode 100644
index 000000000000..3663ab431828
--- /dev/null
+++ b/x11-terms/zutty/metadata.xml
@@ -0,0 +1,26 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>matt@offtopica.uk</email>
+ <name>Matt Smith</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <longdescription lang="en">
+ Zutty is a terminal emulator for the X Window System, functionally
+ similar to several other X terminal emulators such as xterm, rxvt
+ and countless others. It is also similar to other, much more
+ modern, GPU-accelerated terminal emulators such as Alacritty and
+ Kitty. What really sets Zutty apart is its radically simple, yet
+ extremely efficient rendering implementation, coupled with a
+ sufficiently complete feature set to make it useful for a wide
+ range of users. Zutty offers high throughput with low latency, and
+ strives to conform to relevant (published or de-facto) standards.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">tomszilagyi/zutty</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/x11-terms/zutty/zutty-0.8.ebuild b/x11-terms/zutty/zutty-0.8.ebuild
new file mode 100644
index 000000000000..d4ab66148fff
--- /dev/null
+++ b/x11-terms/zutty/zutty-0.8.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="X terminal emulator rendering through OpenGL ES Compute Shaders"
+HOMEPAGE="https://tomscii.sig7.se/zutty/ https://github.com/tomszilagyi/zutty"
+SRC_URI="https://github.com/tomszilagyi/zutty/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+COMMON_DEPEND="
+ media-libs/freetype:2
+ media-libs/libglvnd[X]
+ x11-libs/libXmu"
+DEPEND="
+ ${COMMON_DEPEND}
+ ${PYTHON_DEPS}"
+RDEPEND="${COMMON_DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( doc/KEYS.org doc/USAGE.org )