summaryrefslogtreecommitdiff
path: root/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild')
-rw-r--r--x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild b/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild
new file mode 100644
index 000000000000..4e66f65a8dcc
--- /dev/null
+++ b/x11-themes/gartoon-redux/gartoon-redux-1.10-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+inherit eutils gnome2-utils
+
+DESCRIPTION="A massively improved variant of the well-known Gartoon theme"
+HOMEPAGE="http://gnome-look.org/content/show.php/?content=74841"
+SRC_URI="http://tweenk.artfx.pl/gartoon/source/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-lang/perl
+ dev-perl/Switch
+ gnome-base/librsvg
+"
+
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.10-rsvg-convert.patch
+}
+
+src_configure() {
+ # perl script, not autotools based
+ ./configure --prefix=/usr || die
+}
+
+src_compile() {
+ unset XDG_CACHE_HOME # bug 588708
+ emake prepare
+ emake
+}
+
+src_install() {
+ emake icondir="${D}"/usr/share/icons/GartoonRedux install
+ dodoc AUTHORS changelog README TODO
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }