summaryrefslogtreecommitdiff
path: root/x11-themes/mate-themes/mate-themes-3.22.24.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-12-22 07:49:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-12-22 07:49:59 +0000
commit591f45259704c7c0c4289228107c6ee61457420e (patch)
tree5e8d5d28f7699a5b31d1c2b112b2bb84fe36bc42 /x11-themes/mate-themes/mate-themes-3.22.24.ebuild
parent9f4b8d7fbdb3e35f8854c2e1c63926e383d299ea (diff)
gentoo auto-resync : 22:12:2023 - 07:49:59
Diffstat (limited to 'x11-themes/mate-themes/mate-themes-3.22.24.ebuild')
-rw-r--r--x11-themes/mate-themes/mate-themes-3.22.24.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-themes/mate-themes/mate-themes-3.22.24.ebuild b/x11-themes/mate-themes/mate-themes-3.22.24.ebuild
new file mode 100644
index 000000000000..b5c1ddb91ee8
--- /dev/null
+++ b/x11-themes/mate-themes/mate-themes-3.22.24.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools xdg
+
+MATE_GTK_V="$(ver_cut 1-2)"
+
+HOMEPAGE="https://mate-desktop.org"
+DESCRIPTION="A set of MATE themes, with sets for users with limited or low vision"
+SRC_URI="https://pub.mate-desktop.org/releases/themes/${MATE_GTK_V}/${P}.tar.xz"
+
+LICENSE="CC-BY-SA-3.0 GPL-3+ LGPL-2.1+ LGPL-3"
+SLOT="0/${MATE_GTK_V}"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+
+RDEPEND="
+ >=x11-libs/gdk-pixbuf-2:2
+ >=x11-libs/gtk+-2:2
+"
+
+DEPEND="${RDEPEND}
+ >=sys-devel/gettext-0.19.8:*
+ >=sys-devel/autoconf-2.53
+ >=x11-misc/icon-naming-utils-0.8.7:0
+ virtual/pkgconfig
+"
+
+RESTRICT="binchecks strip"
+
+src_prepare() {
+ default
+ eautoreconf
+}