summaryrefslogtreecommitdiff
path: root/x11-themes/papirus-icon-theme/papirus-icon-theme-20200102.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-01-15 15:51:32 +0000
commit21435953e16cda318a82334ddbadb3b5c36d9ea7 (patch)
treee1810a4b135afce04b34862ef0fab2bfaeb8aeca /x11-themes/papirus-icon-theme/papirus-icon-theme-20200102.ebuild
parent7bc9c63c9da678a7e6fceb095d56c634afd22c56 (diff)
gentoo resync : 15.01.2020
Diffstat (limited to 'x11-themes/papirus-icon-theme/papirus-icon-theme-20200102.ebuild')
-rw-r--r--x11-themes/papirus-icon-theme/papirus-icon-theme-20200102.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/x11-themes/papirus-icon-theme/papirus-icon-theme-20200102.ebuild b/x11-themes/papirus-icon-theme/papirus-icon-theme-20200102.ebuild
new file mode 100644
index 000000000000..5d08cbe8008b
--- /dev/null
+++ b/x11-themes/papirus-icon-theme/papirus-icon-theme-20200102.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2-utils
+
+DESCRIPTION="icon theme for Linux"
+HOMEPAGE="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme"
+SRC_URI="https://github.com/PapirusDevelopmentTeam/papirus-icon-theme/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+src_compile() { :; }
+
+src_install() {
+ insinto /usr/share/icons
+ doins -r ePapirus Papirus{,-Dark,-Light}
+
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }