summaryrefslogtreecommitdiff
path: root/x11-themes/smplayer-themes/smplayer-themes-17.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-themes/smplayer-themes/smplayer-themes-17.2.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-themes/smplayer-themes/smplayer-themes-17.2.0.ebuild')
-rw-r--r--x11-themes/smplayer-themes/smplayer-themes-17.2.0.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-themes/smplayer-themes/smplayer-themes-17.2.0.ebuild b/x11-themes/smplayer-themes/smplayer-themes-17.2.0.ebuild
new file mode 100644
index 000000000000..9b2dd9c1e7e3
--- /dev/null
+++ b/x11-themes/smplayer-themes/smplayer-themes-17.2.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit qmake-utils
+
+DESCRIPTION="Icon themes for smplayer"
+HOMEPAGE="http://www.smplayer.info/"
+SRC_URI="mirror://sourceforge/smplayer/${P}.tar.bz2"
+
+LICENSE="CC-BY-2.5 CC-BY-SA-2.5 CC-BY-SA-3.0 CC0-1.0 GPL-2 GPL-3+ LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-qt/qtcore:4"
+RDEPEND="media-video/smplayer"
+
+src_prepare() {
+ default
+
+ # bug 544108
+ sed -i -e "s| rcc| \"$(qt4_get_bindir)\"/rcc|" themes/Makefile || die
+
+ # bug 544160
+ sed -i -e 's/make/$(MAKE)/' Makefile || die
+}
+
+src_install() {
+ rm themes/Makefile themes/H2O/Makefile || die
+ insinto /usr/share/smplayer
+ doins -r themes
+ dodoc Changelog README.txt
+}