summaryrefslogtreecommitdiff
path: root/x11-themes/vertex-icon-theme
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-21 02:22:31 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-21 02:22:31 +0000
commit3b32ae7547d742f6e65770361188670710bec186 (patch)
tree51b5a45e8291644df70197de17f086e1640e9c7e /x11-themes/vertex-icon-theme
parentdd03974882f85ca04e35cfbc97f7ff756f5d5c20 (diff)
gentoo auto-resync : 21:02:2023 - 02:22:31
Diffstat (limited to 'x11-themes/vertex-icon-theme')
-rw-r--r--x11-themes/vertex-icon-theme/Manifest2
-rw-r--r--x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild34
-rw-r--r--x11-themes/vertex-icon-theme/vertex-icon-theme-20150506.ebuild58
3 files changed, 35 insertions, 59 deletions
diff --git a/x11-themes/vertex-icon-theme/Manifest b/x11-themes/vertex-icon-theme/Manifest
index ac79f38d980a..1508e2841242 100644
--- a/x11-themes/vertex-icon-theme/Manifest
+++ b/x11-themes/vertex-icon-theme/Manifest
@@ -1,3 +1,3 @@
DIST vertex-icon-theme-20150506.tar.gz 5578183 BLAKE2B 59310cdafeff6bc81c70dfb9c2074a1cd4f1dbec4a12ad8fc9598ef0a97f12a0b8ea61ee45bee54d15f024c2c87a0ae981f0e3a2974e3d7ae6b4b6f84eac81e7 SHA512 24176527f50eb2f23621d9dffe9829aba44507939a3ce67dad5480f4297d5004ddccc575b68e86ff9d6db1e5124b89832eff801fab95baf2ca30e305d8083324
-EBUILD vertex-icon-theme-20150506.ebuild 1176 BLAKE2B d0120c6b32563b6d6f4237e483c88d979f3b0b975eca72ce51e960368ca60f30306d128e2c934d82544e8096509063b1c7114f880a17109e63c17b62ce715948 SHA512 671eb5f6e8187e1054fe4dbc0caa5b1191a9006d2e6614c795d0cba6811866b2605bbb9b443e24c1c087b2db2479b0a38ef45bbaacb5a701fb2cbed9bb6e1fba
+EBUILD vertex-icon-theme-20150506-r1.ebuild 889 BLAKE2B cea6f72d8474eb85251e066fc53fc5ba93d565e867b596e979607e46a30d042e62af9759c22ef02a6472e0e8619df99c141db72d75f1062fdd01abf32eae50f3 SHA512 d6aeae01d1724183b510ad5cc13a412179f166a36e2ad7f985a27f38b830fe6b8027e84795d45700da3c636273aca75427cea511498d405a4c70d9f153f2a271
MISC metadata.xml 341 BLAKE2B 8f1c0be246d072c35f98f8eb0228ceaffe5973ff5a9af924459eea7805e542ba67c690ae4110c4178570121cffdfd22c1021375e414ab2de8576d0e3089fe982 SHA512 10f6bbd086f1c8235bc247629743b18f7a56a78db6289f70ea0b2f59033c46d95137bc77776647a86f4c96208ad790b120e72e41bae2c2f8b2db804b52e62e6c
diff --git a/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild b/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild
new file mode 100644
index 000000000000..f1a07a683543
--- /dev/null
+++ b/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506-r1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg
+
+MY_PN="vertex-icons"
+EGIT_COMMIT="f27e47edf392596b7967b7d134d3c62ac3fda0c9"
+
+DESCRIPTION="Vertex icon theme"
+HOMEPAGE="https://github.com/horst3180/vertex-icons"
+SRC_URI="https://github.com/horst3180/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${MY_PN}-${EGIT_COMMIT}"
+
+LICENSE="|| ( GPL-3 GPL-2 LGPL-3 CC-BY-SA-3.0 )"
+SLOT="0"
+KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+RDEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+
+src_configure() { :; }
+
+src_compile() { :; }
+
+src_install() {
+ default
+ rm COPYING README.md || die
+
+ insinto /usr/share/icons/Vertex
+ doins -r .
+}
diff --git a/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506.ebuild b/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506.ebuild
deleted file mode 100644
index efa82421d755..000000000000
--- a/x11-themes/vertex-icon-theme/vertex-icon-theme-20150506.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit gnome2-utils
-
-MY_PN="vertex-icons"
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/horst3180/${MY_PN}"
- SRC_URI=""
-else
- EGIT_COMMIT="f27e47edf392596b7967b7d134d3c62ac3fda0c9"
- SRC_URI="https://github.com/horst3180/${MY_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x64-solaris ~x86-solaris"
- S="${WORKDIR}/${MY_PN}-${EGIT_COMMIT}"
-fi
-
-DESCRIPTION="Vertex icon theme"
-HOMEPAGE="https://github.com/horst3180/vertex-icons"
-
-LICENSE="|| ( GPL-3 GPL-2 LGPL-3 CC-BY-SA-3.0 )"
-SLOT="0"
-IUSE=""
-
-RDEPEND="
- >=x11-themes/hicolor-icon-theme-0.10
-"
-DEPEND=""
-
-# This ebuild does not install any binaries
-RESTRICT="binchecks strip"
-
-src_configure() { :; }
-
-src_compile() { :; }
-
-src_install() {
- default
- rm COPYING README.md || die
-
- insinto /usr/share/icons/Vertex
- doins -r *
-}
-
-pkg_preinst() {
- gnome2_icon_savelist
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}