summaryrefslogtreecommitdiff
path: root/x11-wm/amiwm/amiwm-0.22.01_p20230916.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-16 17:00:58 +0100
commit7b830374520118e805fdd214530a389653750f51 (patch)
tree1f6ef2872a3f89b278b2d5c7f82f36df335dce30 /x11-wm/amiwm/amiwm-0.22.01_p20230916.ebuild
parent3c490942d0d98701d1c0971e60911fa6bd3ecb76 (diff)
gentoo auto-resync : 16:09:2023 - 17:00:58
Diffstat (limited to 'x11-wm/amiwm/amiwm-0.22.01_p20230916.ebuild')
-rw-r--r--x11-wm/amiwm/amiwm-0.22.01_p20230916.ebuild51
1 files changed, 51 insertions, 0 deletions
diff --git a/x11-wm/amiwm/amiwm-0.22.01_p20230916.ebuild b/x11-wm/amiwm/amiwm-0.22.01_p20230916.ebuild
new file mode 100644
index 000000000000..3395a726dd7b
--- /dev/null
+++ b/x11-wm/amiwm/amiwm-0.22.01_p20230916.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+COMMIT="74a398944f9a2c543b6b176e65ed4ee2373b1d65"
+DESCRIPTION="Amiga Workbench inspired window manager for Xorg"
+HOMEPAGE="https://github.com/sdomi/amiwm"
+SRC_URI="https://github.com/chewi/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="amiwm"
+SLOT="0"
+KEYWORDS="~amd64 ~m68k ~ppc ~x86"
+
+COMMON_DEPEND="
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXext
+"
+
+RDEPEND="
+ ${COMMON_DEPEND}
+ media-fonts/font-misc-misc[nls,X]
+ x11-apps/xrdb
+ x11-apps/xsetroot
+"
+
+DEPEND="
+ ${COMMON_DEPEND}
+ x11-base/xorg-proto
+"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ default
+ eautoconf
+}
+
+src_install() {
+ emake install DESTDIR="${D}" STRIPFLAG=
+ einstalldocs
+
+ exeinto /etc/X11/Sessions
+ newexe - ${PN} <<-EOF
+ #!/bin/sh
+ exec ${PN}
+ EOF
+}