summaryrefslogtreecommitdiff
path: root/x11-wm/blackbox
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /x11-wm/blackbox
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'x11-wm/blackbox')
-rw-r--r--x11-wm/blackbox/Manifest1
-rw-r--r--x11-wm/blackbox/blackbox-0.76-r1.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/x11-wm/blackbox/Manifest b/x11-wm/blackbox/Manifest
index b8453d9180e9..8c12d60c7240 100644
--- a/x11-wm/blackbox/Manifest
+++ b/x11-wm/blackbox/Manifest
@@ -1,4 +1,5 @@
AUX blackbox.desktop 128 BLAKE2B 3acb8eec34024ad4b5625d76f16206e40cceb11db194a084ba90b160e54824f95f228999128efe76c7c11509e89e85a2e2fa49f0f00f43777a7f65c0afe2ec01 SHA512 340bf82fdfe40fabe698b0fe9ce371395ab82a0570323663a2d1c3f26a36a2b1628dd91fe691a58d22b599f4cde060a005accc7294b9758cc4220d92f226d28d
DIST blackbox-0.76.tar.gz 394032 BLAKE2B ffefd24277c581ca59216f53c10d5ffacd7231b33c7fd8bfd799a1f93f0b4953ab91f6c8e7061f91ca80036a8a2b8d7b118383e97b8ab58b8f4cd039155760a1 SHA512 bc97ae699820f8291399ce6f2a87ef4486fabcaeda2dc33fbeb31fc6405c01d722a52c85d8dc65ef44bb031e3dda63c326b76aa1bfca3e544bfcab0fac9d1afa
+EBUILD blackbox-0.76-r1.ebuild 1315 BLAKE2B fcd0aafe7b2bbd3059e2cdfb91ac43cd119d5a4f19ba227e984a3542230fa98656ab004be2d5f3fcd95a1c276f91b8ed22c4579f01119a83048b439ee5de4f68 SHA512 997329b4af80e62f83d91cd2a9efedd8c63f8fd149dbb8e472cad53484356fe6e051c35856623625de3458054e5dda1846fc637378ceb0520286c3ea6f7c698f
EBUILD blackbox-0.76.ebuild 1163 BLAKE2B bdd113e78a785fd76f4aa1e98e0a4903053f010901cba52d53b262902842c54851178bd16fb7928abd87962e65565e47d9af493c8216d29144fbaf6e0537259f SHA512 e7b56ba2fed6111fb004f4b87cd5f9db97081a92f6487bde567b43660376157e5d497984ff35dd59e6eb16dc06ea0ec447c5c8bafaacbac5627a54c546ef656b
MISC metadata.xml 572 BLAKE2B 3b4a1463dc3c3d78c92f1b983b66f3b7eebde350932374e9cdee846566f53c7a4bbdfb97006c8fd4bad8e945b0b4f70893853b8ae3d634c3ad3b9d6bd00e7860 SHA512 e4862cf23928cd2fe0db5b6d70caee609139cc48e1e5d2f5551142165c9c839c8c34ad3e8dbf2fb2e027ce4eef759a6d985063a3e7cc0332a72708262f1c8213
diff --git a/x11-wm/blackbox/blackbox-0.76-r1.ebuild b/x11-wm/blackbox/blackbox-0.76-r1.ebuild
new file mode 100644
index 000000000000..f758db45f9e9
--- /dev/null
+++ b/x11-wm/blackbox/blackbox-0.76-r1.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="A small, fast, full-featured window manager for X"
+HOMEPAGE="https://github.com/bbidulock/blackboxwm"
+SRC_URI="https://github.com/bbidulock/blackboxwm/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="debug nls static-libs truetype"
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXt
+ x11-libs/libX11
+ nls? ( >=sys-devel/gettext-0.20 )
+ truetype? ( media-libs/freetype )"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/blackboxwm-${PV}
+
+src_prepare() {
+ sed -e '/AC_DISABLE_SHARED/d' -i configure.ac || die
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/X11/${PN} \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable truetype xft)
+}
+
+src_install() {
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/blackbox" > "${D}/etc/X11/Sessions/${PN}"
+ fperms a+x /etc/X11/Sessions/${PN}
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog* COMPLIANCE README* TODO
+
+ find "${D}" -name '*.la' -delete || die
+ use static-libs || rm "${D}"/usr/$(get_libdir)/libbt.a || die
+}