summaryrefslogtreecommitdiff
path: root/x11-wm/goomwwm/goomwwm-1.0.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-wm/goomwwm/goomwwm-1.0.0-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-wm/goomwwm/goomwwm-1.0.0-r1.ebuild')
-rw-r--r--x11-wm/goomwwm/goomwwm-1.0.0-r1.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/x11-wm/goomwwm/goomwwm-1.0.0-r1.ebuild b/x11-wm/goomwwm/goomwwm-1.0.0-r1.ebuild
new file mode 100644
index 000000000000..8e769cfdc2c4
--- /dev/null
+++ b/x11-wm/goomwwm/goomwwm-1.0.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit toolchain-funcs
+
+DESCRIPTION="Get out of my way, Window Manager!"
+HOMEPAGE="https://github.com/seanpringle/goomwwm"
+SRC_URI="${HOMEPAGE}/archive/${PV}.tar.gz -> ${P}-github.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND="
+ x11-libs/libXft
+ x11-libs/libX11
+ x11-libs/libXinerama
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/xineramaproto
+ x11-proto/xproto
+"
+
+src_prepare() {
+ default
+ sed -i -e 's|$(LDADD) $(LDFLAGS)|$(LDFLAGS) $(LDADD)|g' Makefile || die
+}
+
+src_configure() {
+ use debug && append-cflags -DDEBUG
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) proto normal
+}
+
+src_install() {
+ dobin ${PN}
+ doman ${PN}.1
+}