summaryrefslogtreecommitdiff
path: root/x11-wm/i3/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /x11-wm/i3/files
reinit the tree, so we can have metadata
Diffstat (limited to 'x11-wm/i3/files')
-rw-r--r--x11-wm/i3/files/i3-4.13-remove-git-polling.patch19
-rw-r--r--x11-wm/i3/files/i3-musl-GLOB_TILDE.patch86
2 files changed, 105 insertions, 0 deletions
diff --git a/x11-wm/i3/files/i3-4.13-remove-git-polling.patch b/x11-wm/i3/files/i3-4.13-remove-git-polling.patch
new file mode 100644
index 000000000000..ca226378ed7f
--- /dev/null
+++ b/x11-wm/i3/files/i3-4.13-remove-git-polling.patch
@@ -0,0 +1,19 @@
+diff -Naur a/configure.ac b/configure.ac
+--- a/configure.ac 2017-01-13 13:31:25.250216293 +0100
++++ b/configure.ac 2017-01-13 13:31:55.930217956 +0100
+@@ -146,15 +146,6 @@
+ print_BUILD_MANS=no
+ fi
+
+-git_dir=`git rev-parse --git-dir 2>/dev/null`
+-if test -n "$git_dir"; then
+- srcdir=`dirname "$git_dir"`
+- exclude_dir=`pwd | sed "s,^$srcdir,,g"`
+- if ! grep -q "^$exclude_dir" "$git_dir/info/exclude"; then
+- echo "$exclude_dir" >> "$git_dir/info/exclude"
+- fi
+-fi
+-
+ echo \
+ "--------------------------------------------------------------------------------
+ build configured:
diff --git a/x11-wm/i3/files/i3-musl-GLOB_TILDE.patch b/x11-wm/i3/files/i3-musl-GLOB_TILDE.patch
new file mode 100644
index 000000000000..d241a748186e
--- /dev/null
+++ b/x11-wm/i3/files/i3-musl-GLOB_TILDE.patch
@@ -0,0 +1,86 @@
+From: Natanael Copa <ncopa@alpinelinux.org>
+Patch-Source: https://git.alpinelinux.org/cgit/aports/tree/community/i3wm/musl.patch
+Project-Bug-URL: https://github.com/i3/i3/issues/1859
+Gentoo-Bug-URL: https://bugs.gentoo.org/show_bug.cgi?id=609306
+
+Musl doesn't implement GLOB_TILDE, which is used by i3 when expanding paths.
+
+This patch replaces usage of GLOB_TILDE in glob() by replacing tilde
+with the content of $HOME - if set - manually.
+
+As mentioned in the i3 bugtracker this is an issue that should be solved by musl.
+
+A patch has been sent to musl upstream, but it hasn't been merged yet:
+http://www.openwall.com/lists/musl/2017/01/17/1
+---
+--- i3-4.11/i3bar/src/main.c
++++ i3-4.11/i3bar/src/main.c
+@@ -45,14 +45,20 @@ void debuglog(char *fmt, ...) {
+ *
+ */
+ char *expand_path(char *path) {
+- static glob_t globbuf;
+- if (glob(path, GLOB_NOCHECK | GLOB_TILDE, NULL, &globbuf) < 0) {
+- ELOG("glob() failed\n");
+- exit(EXIT_FAILURE);
++ char *home, *expanded;
++
++ if (strncmp(path, "~/", 2) == 0) {
++ home = getenv("HOME");
++ if (home != NULL) {
++ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
++ expanded = scalloc(strlen(home)+strlen(path), 1);
++ strcpy(expanded, home);
++ strcat(expanded, path+1);
++ return expanded;
++ }
+ }
+- char *result = sstrdup(globbuf.gl_pathc > 0 ? globbuf.gl_pathv[0] : path);
+- globfree(&globbuf);
+- return result;
++
++ return sstrdup(path);
+ }
+
+ void print_usage(char *elf_name) {
+--- i3-4.11/libi3/resolve_tilde.c
++++ i3-4.11/libi3/resolve_tilde.c
+@@ -19,27 +19,18 @@
+ *
+ */
+ char *resolve_tilde(const char *path) {
+- static glob_t globbuf;
+- char *head, *tail, *result;
++ char *home, *expanded;
+
+- tail = strchr(path, '/');
+- head = sstrndup(path, tail ? (size_t)(tail - path) : strlen(path));
+-
+- int res = glob(head, GLOB_TILDE, NULL, &globbuf);
+- free(head);
+- /* no match, or many wildcard matches are bad */
+- if (res == GLOB_NOMATCH || globbuf.gl_pathc != 1)
+- result = sstrdup(path);
+- else if (res != 0) {
+- err(EXIT_FAILURE, "glob() failed");
+- } else {
+- head = globbuf.gl_pathv[0];
+- result = scalloc(strlen(head) + (tail ? strlen(tail) : 0) + 1, 1);
+- strncpy(result, head, strlen(head));
+- if (tail)
+- strncat(result, tail, strlen(tail));
++ if (strncmp(path, "~/", 2) == 0) {
++ home = getenv("HOME");
++ if (home != NULL) {
++ /* new length: sum - 1 (omit '~') + 1 (for '\0') */
++ expanded = scalloc(strlen(home)+strlen(path), 1);
++ strcpy(expanded, home);
++ strcat(expanded, path+1);
++ return expanded;
++ }
+ }
+- globfree(&globbuf);
+
+- return result;
++ return sstrdup(path);
+ }