summaryrefslogtreecommitdiff
path: root/x11-wm/marco
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-06-22 11:40:06 +0100
commit7a86906b67693cc65671d3e1476835d3a7e13092 (patch)
tree9de1b9e2cf77833183d4e5ffab2e94d0403ef725 /x11-wm/marco
parentd56d144655e3785864da43c9acb6c228ef9360ae (diff)
gentoo resync : 22.06.2019
Diffstat (limited to 'x11-wm/marco')
-rw-r--r--x11-wm/marco/marco-1.22.1-r1.ebuild72
1 files changed, 72 insertions, 0 deletions
diff --git a/x11-wm/marco/marco-1.22.1-r1.ebuild b/x11-wm/marco/marco-1.22.1-r1.ebuild
new file mode 100644
index 000000000000..2aebb9ee0bb0
--- /dev/null
+++ b/x11-wm/marco/marco-1.22.1-r1.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MATE2_LA_PUNT="yes"
+
+inherit mate
+
+if [[ ${PV} != 9999 ]]; then
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+DESCRIPTION="MATE default window manager"
+LICENSE="GPL-2"
+SLOT="0"
+
+IUSE="startup-notification test xinerama"
+
+COMMON_DEPEND="
+ dev-libs/atk
+ >=dev-libs/glib-2.50:2
+ >=gnome-base/libgtop-2:2=
+ media-libs/libcanberra[gtk3]
+ x11-libs/cairo
+ >=x11-libs/pango-1.2[X]
+ x11-libs/gdk-pixbuf:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/libXcomposite-0.3
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXpresent
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ >=x11-libs/startup-notification-0.7
+ virtual/libintl
+ xinerama? ( x11-libs/libXinerama )
+ !!x11-wm/mate-window-manager"
+
+RDEPEND="${COMMON_DEPEND}
+ gnome-extra/zenity
+ >=mate-base/mate-desktop-1.20.0"
+
+DEPEND="${COMMON_DEPEND}
+ app-text/yelp-tools
+ >=dev-util/intltool-0.34.90
+ sys-devel/gettext:*
+ virtual/pkgconfig:*
+ x11-base/xorg-proto
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-base/xorg-proto )"
+
+src_configure() {
+ mate_src_configure \
+ --enable-compositor \
+ --enable-render \
+ --enable-shape \
+ --enable-sm \
+ --enable-xsync \
+ $(use_enable startup-notification) \
+ $(use_enable xinerama)
+}
+
+src_install() {
+ mate_src_install
+ dodoc {,doc/}*.txt
+}