summaryrefslogtreecommitdiff
path: root/xfce-base/libxfce4util
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-06-23 07:00:28 +0100
commite23cdda4dbb0c83b9e682ab5e916085a35203da5 (patch)
tree5a4ac448a3b288b731c24d947e0ce52df3cab07b /xfce-base/libxfce4util
parent8187a741807f3e9a9e26304973cf18087dcf2560 (diff)
gentoo resync : 23.06.2018
Diffstat (limited to 'xfce-base/libxfce4util')
-rw-r--r--xfce-base/libxfce4util/Manifest2
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.13.2.ebuild46
2 files changed, 48 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index 255779e5e17b..aa039043ca81 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -1,3 +1,5 @@
DIST libxfce4util-4.13.1.tar.bz2 497192 BLAKE2B 56ec5929df43e2c430c45298a2f7634a539ef1f32598ce4cd038659c93ed5de4f28472f744ab03e3cefd040266c1e1bd415c8b4e9489be8f3930bd6df8d1c5c0 SHA512 1667cc22ff72920d3280725cb40c41f5fba9dcfcba8e357ba85548c7f254a67a3ef942c1b71f0ac5c3a7fe46c8c4cb559a06a8111aa71ce1f6824d1a1c2b5063
+DIST libxfce4util-4.13.2.tar.bz2 509280 BLAKE2B 40f1fb95abff4857e976dd5f3ae8c8ad5e66e2c1c49723735e85124db71d30f204525cd74baf22e31bf405718f378b0c9ac37ec4189e1f4b9941d0eb6fc141ce SHA512 3bbb718f3a6d2213c86695b3f99d1e67c859ce635e5d066b18745d2ee57c0b2eea468b61079d8e2514c2d8f5fa847539d236ec0ed3fd17fecd9d1b36dc3595c4
EBUILD libxfce4util-4.13.1.ebuild 844 BLAKE2B f471a8a51b57b9f4ef8ab3d8861bf7640fe3f25dc1ddf9c43955185b6c10ab05e3e7cd7b49c8516f0a5b6a6a9ded3cbf16e928b113aeb4f82b91839c951c0fed SHA512 7a93bbf44afcf3fc24452d905535996e0a0ae6af27f9a7da06e61ac847de4a9ae75cbeeccc36b49ae55f03b27f78317f29489a36df1a5e789a8fd72e7db8706a
+EBUILD libxfce4util-4.13.2.ebuild 1040 BLAKE2B c52757969560b71249b0441467635b31ae8fbafee578d074599a2f0f3c50e262067560f37d834b9d4e71124a7a0e54cc14043b5bc0c5f0b0a3dae9d79ef2fe05 SHA512 755727b0dc33ebc56ff1cfc68ecb53876f7ee6a0876b1aaa42f40d7be70ad7e7d6c6d34ef261dba8161ce6ad811265d83c3eb8bb9d3148bd5d1e8d9be29a7f1e
MISC metadata.xml 247 BLAKE2B f381ffd75f3fdb2842002ea885015f443cc35334f0420d70a61d6730bd55c11750d6a177831dc7c8564eec4dc3863db6085162e58848b0dceb09799006a1b2c5 SHA512 25494c0053fb7b2ed0f78ecc2de8a8ae08a971db8e15f89e906a1d43177fef53eb9ec5dd075a5c67ddee2be112c0943f6c87e4870d405436bddfea3a4fa19203
diff --git a/xfce-base/libxfce4util/libxfce4util-4.13.2.ebuild b/xfce-base/libxfce4util/libxfce4util-4.13.2.ebuild
new file mode 100644
index 000000000000..6686fd3a1762
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.13.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="https://git.xfce.org/xfce/libxfce4util/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.30:=
+ introspection? ( dev-libs/gobject-introspection:= )
+ vala? ( $(vala_depend) )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}