summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.3.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.3.0-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.3.0-r1.ebuild')
-rw-r--r--xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.3.0-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.3.0-r1.ebuild b/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.3.0-r1.ebuild
new file mode 100644
index 000000000000..81097a1aec5a
--- /dev/null
+++ b/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.3.0-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vala meson
+
+DESCRIPTION="Simple ALSA volume control for xfce4-panel"
+HOMEPAGE="https://github.com/equeim/xfce4-alsa-plugin"
+SRC_URI="https://github.com/equeim/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 ~ppc64 ~riscv x86"
+
+RDEPEND="
+ media-libs/alsa-lib
+ >=xfce-base/xfce4-panel-4.13
+ x11-libs/gtk+:3[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ sys-devel/gettext
+"
+
+src_configure() {
+ vala_setup
+ meson_src_configure
+}