summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-cpugraph-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /xfce-extra/xfce4-cpugraph-plugin
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'xfce-extra/xfce4-cpugraph-plugin')
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.6.ebuild37
2 files changed, 39 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-cpugraph-plugin/Manifest b/xfce-extra/xfce4-cpugraph-plugin/Manifest
index c5c5aa41a20b..0c42ac523d80 100644
--- a/xfce-extra/xfce4-cpugraph-plugin/Manifest
+++ b/xfce-extra/xfce4-cpugraph-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-cpugraph-plugin-1.2.5.tar.bz2 455357 BLAKE2B 8408338e7bd858940b1c8b25d8c5f622e72bbbcd61a5b96d44a9c4a88438fac476d1911cbf65f42b8bca9c478e7703cbc2e6ce2668d1b5ef9cd4d68076df6113 SHA512 1a0b362afa2dcae30721dc468e31949e4edfe20f5e1063603111d0cd7fcbd3460f14d7ffd30ae1d687400661c37a51a9c1b2f7abedea6c9e9888e93fbbb56d4a
+DIST xfce4-cpugraph-plugin-1.2.6.tar.bz2 458058 BLAKE2B 4cd7c9734a52b39d0606f25d5ae559230819e5672b6fe8fb4f19ed5afcf9a446790fe38753ef294ae99767bf06ae9ae08ebd85d66a83dcfb675d945ae2771d00 SHA512 6205a0a7616b0dc5de3cdeb79a5148ee775b426a16b52c491129f74104ab224ec3b29b042a3c8ee05b77cc8775c83d75a8312b96a71504cde50dc257e8354857
EBUILD xfce4-cpugraph-plugin-1.2.5.ebuild 855 BLAKE2B 10e62b028e05ed63a1ab692a21bf2220e26616c82c1dd1f3810db8f93650825d5c415d1d206204d98afeb7392d35908151734923286dc5ef8258100541d77889 SHA512 027aefdcb5b6c7ea199757bff039948115ed6afe6571ddbd43f3bac5a16bb163f77748a3b9d6b81fb406817fc14b0b6bf61a6f3b7873a675d9d6748f4b8b8ee6
+EBUILD xfce4-cpugraph-plugin-1.2.6.ebuild 858 BLAKE2B a13f18254309eefb2ec2a547c721c17e7c2e2355a74bd57076a98b8709fb53ce5ac03a308f2c58736d4fd817f51ede31ad3d9076998beae3271824d6d68de1da SHA512 337a2be56415c5ce1afdd6aae01a15701ac065057a267c88c4ea58673698dea077a09323b9024a39750c27d49661846cedda7553bf59e5b61f7bf5d2088558ab
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.6.ebuild b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.6.ebuild
new file mode 100644
index 000000000000..f47b3c810542
--- /dev/null
+++ b/xfce-extra/xfce4-cpugraph-plugin/xfce4-cpugraph-plugin-1.2.6.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="A system load plug-in for the Xfce panel"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-cpugraph-plugin"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2 GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=">=x11-libs/gtk+-3.22:3
+ >=xfce-base/libxfce4ui-4.14:=
+ >=xfce-base/libxfce4util-4.14:=
+ >=xfce-base/xfce4-panel-4.14:="
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}