summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild')
-rw-r--r--xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild b/xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild
new file mode 100644
index 000000000000..c341080b2a87
--- /dev/null
+++ b/xfce-extra/xfce4-dict/xfce4-dict-0.8.4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit xdg-utils
+
+DESCRIPTION="A dict.org querying application and panel plug-in for the Xfce desktop"
+HOMEPAGE="https://goodies.xfce.org/projects/applications/xfce4-dict"
+SRC_URI="https://archive.xfce.org/src/apps/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm ~hppa ~ia64 ppc ppc64 ~sparc x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11
+ >=xfce-base/libxfce4util-4.10:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/xfce4-panel-4.10:="
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen
+ dev-util/intltool
+ virtual/pkgconfig"
+
+src_configure() {
+ econf --libexecdir="${EPREFIX}"/usr/$(get_libdir)
+}
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}