summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-places-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-20 11:23:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-20 11:23:36 +0100
commitc17e7d2a8cc12551a02d28209cd2edbf078d5675 (patch)
treecde162c484c03f53827a78ec75a7f153d18933d3 /xfce-extra/xfce4-places-plugin
parent295483480d7b8ba2fff987fdd32eaa36fe730ce4 (diff)
gentoo auto-resync : 20:09:2022 - 11:23:36
Diffstat (limited to 'xfce-extra/xfce4-places-plugin')
-rw-r--r--xfce-extra/xfce4-places-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.2.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-places-plugin/Manifest b/xfce-extra/xfce4-places-plugin/Manifest
index d1ab46b0d78b..bc098a7afbfb 100644
--- a/xfce-extra/xfce4-places-plugin/Manifest
+++ b/xfce-extra/xfce4-places-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-places-plugin-1.8.1.tar.bz2 380906 BLAKE2B 3b5c82fe3fb9fbcc0b9aa79df62da06025f5dd154d4323787d52cbf659351dcc808a4c6e8d4148332eb31a8d292b51d58dba6c81fdf49443b94928a1e82f66f0 SHA512 c0db29050df6ff2862a6ebc6f89d92e39f0c0511f9e719a979b5132935655078a5f5418b8b87bee2fbccaa37f5489d503dc1ae329eb7fd88970dc55b31db3324
+DIST xfce4-places-plugin-1.8.2.tar.bz2 388168 BLAKE2B 4ffd6fddae71c40c82dd86427c742865a237d48650480db9b817e04f35d6b142896f51f63772f9ab3ca15f1fdccee492d442ee78a1033394154e561075ee66ac SHA512 ad298407183ea499bd4a7c923e80141886c7ca809f4af4184074a1c98e73c72fbf610e06bccdffe3c1bacce39d945dc094d0ea9a82ca67ff7f8b79c8d9c5c53d
EBUILD xfce4-places-plugin-1.8.1.ebuild 1025 BLAKE2B 621a7752289deb3a713bd963c02d3cfffe74f3fa6ba31530862007400cb786b5d085304c3c9d1dba662a71c382438b5eec95b3c24bf782923bbdc18914afee78 SHA512 9fa7d9014516a799352b39831e6ba7f7bcfb2680f866375a00a7761cd4cb16bc9de1ece412898c96d87225ed7c685cc25a600b2ce04bf23d84a7ddd828bb4c12
+EBUILD xfce4-places-plugin-1.8.2.ebuild 1108 BLAKE2B 5097ead3a69b957b0d1910dc5f2019e7a7fba7cfd8790458a8ec2e46a2ffba63f02843b877df998454ce6a36176ab8ea27036c1faaded7d314ef92b5b1ca4ba7 SHA512 251f777ac9e92811dd4af1fe8cc35874889db0645c2d4edc20d38bb48140bebdf8ccc736c9c322e6a4e8b69a357857594983a87f146c51719d8b38cdd638d529
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.2.ebuild b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.2.ebuild
new file mode 100644
index 000000000000..6dbca3313e8d
--- /dev/null
+++ b/xfce-extra/xfce4-places-plugin/xfce4-places-plugin-1.8.2.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A panel plug-in to provide quick access to files, folders and removable media"
+HOMEPAGE="
+ https://goodies.xfce.org/projects/panel-plugins/xfce4-places-plugin
+ https://gitlab.xfce.org/panel-plugins/xfce4-places-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="libnotify"
+
+DEPEND="
+ >=dev-libs/glib-2.50:2
+ >=x11-libs/gtk+-3.22:3
+ x11-libs/libX11:=
+ >=xfce-base/exo-0.6:=
+ >=xfce-base/libxfce4ui-4.13:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ libnotify? ( >=x11-libs/libnotify-0.7:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable libnotify notifications)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}