summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-statusnotifier-plugin/xfce4-statusnotifier-plugin-0.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /xfce-extra/xfce4-statusnotifier-plugin/xfce4-statusnotifier-plugin-0.1.0.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'xfce-extra/xfce4-statusnotifier-plugin/xfce4-statusnotifier-plugin-0.1.0.ebuild')
-rw-r--r--xfce-extra/xfce4-statusnotifier-plugin/xfce4-statusnotifier-plugin-0.1.0.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-statusnotifier-plugin/xfce4-statusnotifier-plugin-0.1.0.ebuild b/xfce-extra/xfce4-statusnotifier-plugin/xfce4-statusnotifier-plugin-0.1.0.ebuild
new file mode 100644
index 000000000000..01a0cd1f11aa
--- /dev/null
+++ b/xfce-extra/xfce4-statusnotifier-plugin/xfce4-statusnotifier-plugin-0.1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="A panel area for fd.o Status Notifiers (systray replacement)"
+HOMEPAGE="https://goodies.xfce.org/projects/panel-plugins/xfce4-statusnotifier-plugin"
+SRC_URI="mirror://xfce/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="
+ >=dev-libs/glib-2.24:=
+ >=dev-libs/libdbusmenu-16.04.0:=[gtk3]
+ >=x11-libs/gtk+-3.18:3=
+ x11-libs/libX11:=
+ >=xfce-base/libxfce4ui-4.12:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfce4-panel-4.12:=
+ >=xfce-base/xfconf-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/gdbus-codegen"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}