summaryrefslogtreecommitdiff
path: root/xfce-extra/xfce4-systemload-plugin
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-03 21:12:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-03 21:12:43 +0000
commit924750a8c767b278c9870be5dcfedced436f1276 (patch)
treed5c93de95fb5c2fa090e76fd12c1535698005868 /xfce-extra/xfce4-systemload-plugin
parenta4d4c6a7cf31d8d3248101dbfd654cdc416902ac (diff)
gentoo auto-resync : 03:11:2022 - 21:12:43
Diffstat (limited to 'xfce-extra/xfce4-systemload-plugin')
-rw-r--r--xfce-extra/xfce4-systemload-plugin/Manifest2
-rw-r--r--xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-systemload-plugin/Manifest b/xfce-extra/xfce4-systemload-plugin/Manifest
index 2c85cf12be1b..8c7d947dd1e6 100644
--- a/xfce-extra/xfce4-systemload-plugin/Manifest
+++ b/xfce-extra/xfce4-systemload-plugin/Manifest
@@ -1,3 +1,5 @@
DIST xfce4-systemload-plugin-1.3.1.tar.bz2 417959 BLAKE2B c9255349cb4f20a8d8165fbf5a124dbffcb4ca3633c32ca7b2cbbebc4770a50a24909158cd3fcaad9f8bab4b756b98b5329b60a1fbbd0ac0be13251bb950d542 SHA512 2b2285c5960a5728dd7818f90605848e462fe5fef8643ff5be64b7087225399395ace5ec8013f6795d410b0acf79ec77c14e2ed0e56007cfe6f13133ba708876
+DIST xfce4-systemload-plugin-1.3.2.tar.bz2 409767 BLAKE2B 1213c007431318628f4f81026ccdbca2e5b9d34462d66354a1c37999aadc0ef9ed84246bc7f185fd633898364dc0440297dde18288f8beea1d5c7bf6663a6a04 SHA512 f432988f439e5fd7ada16b3e6eaa42b3351531ba3e2b63e2570387bf4d7e605ff9d5a97fde3f5f5eb323ff08aaf3c050f161a5768392b80aa99fabaabda82431
EBUILD xfce4-systemload-plugin-1.3.1.ebuild 1024 BLAKE2B 083b795561b3a767a621129df90d2eb3faae1198ea46cb320469352acdb56ea2589d8a98992f1785b150d02c6ef752b1ea154697f6d00871d21a4d792da17266 SHA512 1c2ab2f8aa8f4783b4f42cdf845995b35ae6fd8c6d4cbb54941b04d1c359d351df29dc64e7f7b4accfabf6a9784487fbd208cbac6849e77cf06633f04b4bb6b9
+EBUILD xfce4-systemload-plugin-1.3.2.ebuild 1131 BLAKE2B 8bb221c625ac9d5228844ef517402f92d84e31607b28b74ca96cfbc4048be3a7a22972be57b497f5ad23cf9afc669732923a3a7d0f0e74c8db7445516830738c SHA512 c58f890bd4508f2540cee94b5bfb20620e535701cd7cb7544a36c90f05e1918ea1b59238926251dbc65b99e1f6568c8c891294835837daa1dc21729c94259460
MISC metadata.xml 248 BLAKE2B 83bf47dc3dbedea8a88932e922075f0ba8fd841433c4ab750e2ab61c22e8cbfaa1acb04a903d89ef5140a75dfc4c4899354623e0160df5b7c178c190f8494515 SHA512 b5200cfe30adef8e869fada87f1b4171210b2427cd3ac12edef70948f305d5e612ca5f24d377f9823a6022c8867db635db50ddd3d6cb362d6b0137c299fe07e5
diff --git a/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2.ebuild b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2.ebuild
new file mode 100644
index 000000000000..986094ce17a5
--- /dev/null
+++ b/xfce-extra/xfce4-systemload-plugin/xfce4-systemload-plugin-1.3.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="System load plug-in for Xfce panel"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-systemload-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-systemload-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="upower"
+
+DEPEND="
+ >=xfce-base/libxfce4ui-4.16:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.17.2:=
+ >=xfce-base/xfce4-panel-4.16:=
+ >=xfce-base/xfconf-4.14:=
+ upower? ( >=sys-power/upower-0.9.23 )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local myconf=(
+ # gtop is needed only as fallback when /proc is not available
+ --disable-libgtop
+ $(use_enable upower)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}