summaryrefslogtreecommitdiff
path: root/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility/yasr/yasr-0.6.9-r1.ebuild')
-rw-r--r--app-accessibility/yasr/yasr-0.6.9-r1.ebuild45
1 files changed, 23 insertions, 22 deletions
diff --git a/app-accessibility/yasr/yasr-0.6.9-r1.ebuild b/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
index 2bf8a4603be6..b9e8c1573d6e 100644
--- a/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
+++ b/app-accessibility/yasr/yasr-0.6.9-r1.ebuild
@@ -1,10 +1,11 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
-inherit autotools eutils
+EAPI=6
-DESCRIPTION="general-purpose console screen reader"
+inherit autotools
+
+DESCRIPTION="General-purpose console screen reader"
HOMEPAGE="http://yasr.sourceforge.net/"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -16,36 +17,36 @@ IUSE="nls"
RDEPEND=""
DEPEND="nls? ( sys-devel/gettext )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6.9-automake113.patch
+ "${FILESDIR}"/${PN}-0.6.9-gettext019.patch
+ "${FILESDIR}"/${PN}-0.6.9-gcc43.patch
+ "${FILESDIR}"/${PN}-0.6.9-remove-m4.patch
+)
+
src_prepare() {
+ default
local x=/usr/share/gettext/po/Makefile.in.in
- [[ -e $x ]] && cp -f $x po/ #330879
+ [[ -e $x ]] && cp -f $x po/ || die #330879
+
+ rm -r "${S}"/m4 || die
- epatch "${FILESDIR}"/${P}-automake113.patch \
- "${FILESDIR}"/${P}-gettext018.patch \
- "${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-remove-m4.patch
+ sed -i \
+ 's:^\(synthesizer=emacspeak server\):#\1:
+ s:^\(synthesizer port=|/usr/local/bin/eflite\):#\1:
+ s:^#\(synthesizer=speech dispatcher\):\1:
+ s:^#\(synthesizer port=127.0.0.1.6560\):\1:' yasr.conf || die
- rm -r "${S}"/m4
+ mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
econf \
- --datadir=/etc \
- --disable-dependency-tracking \
+ --datadir="${EPREFIX}"/etc \
$(use_enable nls)
}
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc README ChangeLog AUTHORS BUGS CREDITS
- dosed \
- 's:^\(synthesizer=emacspeak server\):#\1:
- s:^\(synthesizer port=|/usr/local/bin/eflite\):#\1:
- s:^#\(synthesizer=speech dispatcher\):\1:
- s:^#\(synthesizer port=127.0.0.1.6560\):\1:' /etc/yasr/yasr.conf
-}
-
pkg_postinst() {
elog
elog "Speech-dispatcher is configured as the default synthesizer for yasr."