summaryrefslogtreecommitdiff
path: root/app-accessibility
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/Manifest.gzbin4709 -> 4711 bytes
-rw-r--r--app-accessibility/at-spi2-core/Manifest2
-rw-r--r--app-accessibility/at-spi2-core/at-spi2-core-2.48.0.ebuild67
-rw-r--r--app-accessibility/orca/Manifest2
-rw-r--r--app-accessibility/orca/orca-44.0.ebuild59
5 files changed, 130 insertions, 0 deletions
diff --git a/app-accessibility/Manifest.gz b/app-accessibility/Manifest.gz
index 6cd4de54a6d9..5c01f5c01326 100644
--- a/app-accessibility/Manifest.gz
+++ b/app-accessibility/Manifest.gz
Binary files differ
diff --git a/app-accessibility/at-spi2-core/Manifest b/app-accessibility/at-spi2-core/Manifest
index 88b8cb1f2f47..d5dc04a9be8b 100644
--- a/app-accessibility/at-spi2-core/Manifest
+++ b/app-accessibility/at-spi2-core/Manifest
@@ -1,3 +1,5 @@
DIST at-spi2-core-2.46.0.tar.xz 540600 BLAKE2B e3ed9915c39a9f71b64a9753c7f91208d15289fe09a9505b4766df7fa04c3e6e5cdc7b3702315eabbdf70f9fc08b4cca4546353485328ab101e2950a672885d6 SHA512 633af2c02fab3b8cb02e37f929ce80dd5ce28ca5641046ef5e25cb29299530b90028e6c6f318a0c098a4270bed3eab48fb55d6967a76bfadd2520f49de47c770
+DIST at-spi2-core-2.48.0.tar.xz 554000 BLAKE2B b8f513256670d24ae9f08572ae7878f109b5d76090fa4f881b67324d1d270889c648e456fe3ca34aaead9e85589f5ae355c8b4803f35c2cb2ace831051b1000b SHA512 976dce741d640c5b5e006eca53170062ebc91cace0fb74df68606c8443b63317fe271d4e3238d1e3ee3e5586b4a4905c91d7987adb94c8f886a1aaddd54c632e
EBUILD at-spi2-core-2.46.0.ebuild 1465 BLAKE2B f80766774966d17a0118d0b3e5f843648abd1f2c17c3768a1e30c0f5ec24792fb85cbec5e34d6c9e375f69c59b4567c6163850266472e77e9f79e602eb90b236 SHA512 1cabedef0fc8bd01dff37edd018f9aff71857cd206d487a0b36d2e4442144ad95a0685cbfc5711cef20579b40e0c14b860b87a4fe33207024745ac4e49da98b8
+EBUILD at-spi2-core-2.48.0.ebuild 1793 BLAKE2B 6cccb8a9eaf7839554404ea18105eeeabeaefaa0b91625b9d981e6ed53e8b921f23ae12e2c9903c62aa4034d64ee95c2416da89fa3e3569042b7233a65a3c35c SHA512 d431a4ebee9585dc3e4fdbf9392c51770951e88a2de91905e91b40712c87eded0bb63c70026d1ca938b8772571a77a20d688972fd364eb12042aa102349f949c
MISC metadata.xml 353 BLAKE2B a11426ebcc6d7d5d3b6af03001b0da28239ca8374757211ed13e13b2d23f0580a4bbd8a7bdc2f6db655dbff2f4dba8288f45385f628e8b95fb3d5f8ad74fce3b SHA512 ccd21495d004a42ffeb05aeac3667f198b2c21b10c7df7ce7cded2593c668be08c5c5dc3315f52dbda423a3236be6d1ad9a4769f9d753760d5e84a06ffb62281
diff --git a/app-accessibility/at-spi2-core/at-spi2-core-2.48.0.ebuild b/app-accessibility/at-spi2-core/at-spi2-core-2.48.0.ebuild
new file mode 100644
index 000000000000..0ec5d49b8cfa
--- /dev/null
+++ b/app-accessibility/at-spi2-core/at-spi2-core-2.48.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gnome.org meson-multilib systemd virtualx xdg
+
+DESCRIPTION="D-Bus accessibility specifications and registration daemon"
+HOMEPAGE="https://wiki.gnome.org/Accessibility https://gitlab.gnome.org/GNOME/at-spi2-core"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+IUSE="X gtk-doc +introspection"
+REQUIRED_USE="gtk-doc? ( X )"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ >=sys-apps/dbus-1.5[${MULTILIB_USEDEP}]
+ >=dev-libs/glib-2.67.4:2[${MULTILIB_USEDEP}]
+ >=dev-libs/libxml2-2.9.1:2[${MULTILIB_USEDEP}]
+ introspection? ( >=dev-libs/gobject-introspection-1.54.0:= )
+ X? (
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ )
+
+ !<dev-libs/atk-2.46.0
+ !<app-accessibility/at-spi2-atk-2.46.0
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-util/glib-utils
+ gtk-doc? (
+ dev-python/sphinx
+ dev-util/gdbus-codegen
+ >=dev-util/gi-docgen-2021.1
+ )
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ local emesonargs=(
+ -Dsystemd_user_dir="$(systemd_get_userunitdir)"
+ $(meson_native_use_bool gtk-doc docs)
+ $(meson_native_use_feature introspection)
+ $(meson_feature X x11)
+ -Ddisable_p2p=false
+ -Datk_only=false
+ )
+ meson_src_configure
+}
+
+multilib_src_test() {
+ virtx dbus-run-session meson test -C "${BUILD_DIR}" || die
+}
+
+multilib_src_install_all() {
+ einstalldocs
+
+ if use gtk-doc; then
+ mkdir -p "${ED}"/usr/share/gtk-doc/{libatspi,atk} || die
+ mv "${ED}"/usr/share/doc/libatspi "${ED}"/usr/share/gtk-doc/libatspi/html || die
+ mv "${ED}"/usr/share/doc/atk "${ED}"/usr/share/gtk-doc/atk/html || die
+ fi
+}
diff --git a/app-accessibility/orca/Manifest b/app-accessibility/orca/Manifest
index de4db29110b1..25541ade4c0b 100644
--- a/app-accessibility/orca/Manifest
+++ b/app-accessibility/orca/Manifest
@@ -1,3 +1,5 @@
DIST orca-43.1.tar.xz 3761604 BLAKE2B 924fce7c03abe51b46c406f9627f78a18700ad980adc52d9b522cecf73d07a978f4546fd3aec77ab92217627642928ba2ffb2ee73bb7a25163fb3610fa57cb9b SHA512 5d3ade5ae3c4f9b7ed8dfcabddbf7bcf5e2e15e731e0d9c1c69da692e9ce70d270aedcbfc8557a56ca0f2935b2c0c84e21fa4c6db64ec1c01c78dda7a429623f
+DIST orca-44.0.tar.xz 3764020 BLAKE2B 0ac7f837cf38cf15b63400d7ca7d631b4e3710680ea50c311ea60b81e57797e81411f6d2f82cde8434fab065e07a14a7e5d9192e73bf29bb79ac6fa9644d985f SHA512 7b1d4a8417283fc7586bd1a308529d8cc3bdc53f080b5bcd6f9dffc686b9eeeb6992df9d970996b44a3339492fb31bdc26c107cc5233521c655e46d4bea7efb2
EBUILD orca-43.1.ebuild 1451 BLAKE2B 6acffef03ade31e8ad05ec8e64e20854f2691ad658711bb9e1f92ceef4689a1a320b808abc803399b9a98ec0990acdda5bcc2fb77233c15767a2fcc0162d990e SHA512 d4fa4b79fe791ef525c2b49db758370f991456df760f790ebc977db8caffb61ae277302f587a4e66c14552ab4e13d98cefe69a9ff8d314b9d9e0ca32d4d170e0
+EBUILD orca-44.0.ebuild 1454 BLAKE2B 7b803b9033ed7829b154ed39fd9f9e30db703bfe36800ca73e892e30e3507fd289657ee8d4b27d25bab7d51e5f14436da7e929f93c647fecca31ab816defd130 SHA512 f3fe7c0e022533d15e0bb94a4c9455981bf2c0f1a78878951a951ca77178567b09e127c8e15073b06833fce4bf75c5f67fcd49198cd776393a79d0264233b02f
MISC metadata.xml 762 BLAKE2B fca9ee6ac93d2e860f6791af78380e9d8d29ac10b254299946911a29b5893028e561a18320bc026dd7e9421f3c572e1c3ac63264276a1b292996db93e1cba4a3 SHA512 6bbe0cff5af52cb48adccbb61620fd75a0811cad313867b63cb09b5a7c259230019a54ad607ee46c986188ff11ac2f6878ef20381ef34965dfe918c88ec945d0
diff --git a/app-accessibility/orca/orca-44.0.ebuild b/app-accessibility/orca/orca-44.0.ebuild
new file mode 100644
index 000000000000..6b60291784d7
--- /dev/null
+++ b/app-accessibility/orca/orca-44.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit gnome2 python-single-r1
+
+DESCRIPTION="Extensible screen reader that provides access to the desktop"
+HOMEPAGE="https://wiki.gnome.org/Projects/Orca"
+
+LICENSE="LGPL-2.1+ CC-BY-SA-3.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~loong ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+IUSE="+braille"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+DEPEND="${PYTHON_DEPS}
+ >=app-accessibility/at-spi2-core-2.47:2[introspection]
+ >=dev-libs/glib-2.28:2
+ media-libs/gstreamer:1.0[introspection]
+ >=x11-libs/gtk+-3.6.2:3[introspection]
+ $(python_gen_cond_dep '
+ dev-python/gst-python:1.0[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3.18:3[${PYTHON_USEDEP}]
+ ')
+ braille? (
+ $(python_gen_cond_dep '
+ >=app-accessibility/brltty-5.0-r3[python,${PYTHON_USEDEP}]
+ dev-libs/liblouis[python,${PYTHON_USEDEP}]
+ ')
+ )
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ >=app-accessibility/speech-dispatcher-0.8[python,${PYTHON_USEDEP}]
+ >=dev-python/pyatspi-2.36[${PYTHON_USEDEP}]
+ dev-python/setproctitle[${PYTHON_USEDEP}]
+ ')
+ x11-libs/libwnck:3[introspection]
+ x11-libs/pango[introspection]
+"
+BDEPEND="
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+# app-text/yelp-tools
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_with braille liblouis)
+}
+
+src_install() {
+ gnome2_src_install
+ python_optimize
+}