summaryrefslogtreecommitdiff
path: root/app-accessibility
diff options
context:
space:
mode:
Diffstat (limited to 'app-accessibility')
-rw-r--r--app-accessibility/Manifest.gzbin4223 -> 4224 bytes
-rw-r--r--app-accessibility/brltty/Manifest2
-rw-r--r--app-accessibility/brltty/brltty-6.7.ebuild222
3 files changed, 224 insertions, 0 deletions
diff --git a/app-accessibility/Manifest.gz b/app-accessibility/Manifest.gz
index f31584f78c9c..248f5bf5e025 100644
--- a/app-accessibility/Manifest.gz
+++ b/app-accessibility/Manifest.gz
Binary files differ
diff --git a/app-accessibility/brltty/Manifest b/app-accessibility/brltty/Manifest
index 16757214fe7b..16e880575835 100644
--- a/app-accessibility/brltty/Manifest
+++ b/app-accessibility/brltty/Manifest
@@ -2,6 +2,8 @@ AUX brltty-6.4-respect-AR.patch 385 BLAKE2B 0029b98054c21b86bb3d03ff52a358fd0858
AUX brltty-6.6-cython3.patch 1594 BLAKE2B d18b09f888e688efb8a33c0de6cbde25956d1024caa74484b49a48ec65d4dfba06166e26094add5696ba8f8b0563956ff743c81b0510b20db8918ad17ed37f92 SHA512 d4e596a24fbc66629cf935bb6c4c259c594b287a2ea187a362484cd7343247b413f11615afaeb35d761f9497d113d5305819b19830558def0d805036fc4c7149
AUX brltty.initd 241 BLAKE2B 80969e4840d2d38af6bc310ecf18e0253ef01667517135bc5a2f92e50882c2b72e8a4763b215c62ccbfd8d2250067b44ce9a4cb5d318dd6eb48b298826d8d5de SHA512 55ea97a546a2335ee1148396df71363442b66ed4526f8adb93e88c2cf489f10a21b5361658f590b3f64eec24844235491b15349bd0e1c4533fef7b1390fc3a6e
DIST brltty-6.6.tar.xz 3684592 BLAKE2B c1ae05b925384f3869d3c90ccc06197da2a592691830504ff01a530da87319d463e25cd7b387805c199562be815ca4e79f3679f592f3a1107025e3aba17ec159 SHA512 852bfd9179570be7b0da8b1279f84bdfedc14a319988d9c2eac5a20a9ce8977f31fdee167e8e96bb411184a1d72f4cdc633944c7b3f55bddae411fc71a9e6898
+DIST brltty-6.7.tar.xz 3727940 BLAKE2B 61ef2d5e54a53132fe9e864c6c7c8c5ee7af4974fb1a090d9366fbdf7fe0735ca0a4c462cef2fa820d07335f442471af148707a191bb1d631f203ddc5e8f5d2e SHA512 68ef75369ce2a23dff17b212aec0844b5e3e416cc730bdf872d68f32b0d8398f86d1e91f076dcb1730543c3d47266a40d7d61842524076d2fd4e82ef95bc34bb
EBUILD brltty-6.6-r1.ebuild 5794 BLAKE2B ccde2aaee0aa12942a342d1ed721504d588e4be571c2118a5f5ed2e19bf3d23cd5ee5a647efc8f989bdbfd55802df1e55070ba1463f1e7b9812c2ba313bd835c SHA512 7edef9d53a1ff701ffe92396b6bd59261afeed731f99fa8e8e087f5112c41d2e87f7497e37c3b0e5d772de8aec1d7fe0139e01d6f60d87467e85ebc59577ab1c
EBUILD brltty-6.6-r2.ebuild 5762 BLAKE2B 0c939ed96a5eb25f6e663f81ceff31f41e2bbe3715ddd72725dbcd00fb28c3e25f5b2d232b00301b838ecf53e5bcb642bfbb81b0db492f01620f98cdd618742d SHA512 7fcfa96a5ac9abb87d602d5edd4cd8a676b43486f90ca33bbe52fe6acf8223b765f0bf61e586e0e00aa57b63fa4eb342431e26d4bf515fc55a20851a0e69dabf
+EBUILD brltty-6.7.ebuild 5804 BLAKE2B 24d3f87939e27c98d3fe82660ff92571840a86fb782539b7ce15df5c5dc9f24b7e37867c4631becd280258f20da51b53682f04039a5eac02b65563afc648b5bd SHA512 26527c3875476d269db971f4e05c8e6346edeb26d881e449c143492809f7816f8d54fd8ae8f11b1d12c02a83b2230d1ec57c774b4fe8a39644edf6a251423c9a
MISC metadata.xml 1596 BLAKE2B a0eb74542a3ad8ea8d36e269d9c0c9266b1dda440ff9c5a02b53f60c9b406e30c55d7ef58a2c49d02348b410515fb2b4ca5d36e152f006b9bab7445577441a6e SHA512 369c801ef0a8be96d66c2c163fa6000fcf35b49fd83a5521d93a6a2bac5da1f540c2fa977198fc651451959f804a9e3b3630ca8a0470231892861ed1d5cc5b6f
diff --git a/app-accessibility/brltty/brltty-6.7.ebuild b/app-accessibility/brltty/brltty-6.7.ebuild
new file mode 100644
index 000000000000..757a551b42a5
--- /dev/null
+++ b/app-accessibility/brltty/brltty-6.7.ebuild
@@ -0,0 +1,222 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+FINDLIB_USE="ocaml"
+JAVA_PKG_WANT_SOURCE="1.8"
+JAVA_PKG_WANT_TARGET="1.8"
+
+inherit findlib toolchain-funcs java-pkg-opt-2 autotools python-r1 tmpfiles
+
+DESCRIPTION="Daemon that provides access to the Linux/Unix console for a blind person"
+HOMEPAGE="https://brltty.app/"
+SRC_URI="https://brltty.app/archive/${P}.tar.xz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+api +beeper bluetooth doc +fm gpm iconv icu
+ java louis +midi ncurses nls ocaml +pcm policykit python
+ usb systemd +speech tcl xml X"
+REQUIRED_USE="doc? ( api )
+ java? ( api )
+ ocaml? ( api )
+ python? ( api ${PYTHON_REQUIRED_USE} )
+ tcl? ( api )"
+
+COMMON_DEPEND="
+ acct-group/brltty
+ acct-user/brltty
+ dev-libs/libpcre2[pcre32]
+ bluetooth? (
+ sys-apps/dbus
+ net-wireless/bluez
+ )
+ gpm? ( >=sys-libs/gpm-1.20 )
+ iconv? ( virtual/libiconv )
+ icu? ( dev-libs/icu:= )
+ louis? ( dev-libs/liblouis:= )
+ midi? ( media-libs/alsa-lib )
+ ncurses? ( sys-libs/ncurses:0= )
+ pcm? ( media-libs/alsa-lib )
+ policykit? ( sys-auth/polkit )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ )
+ speech? (
+ app-accessibility/espeak-ng
+ app-accessibility/flite
+ app-accessibility/speech-dispatcher
+ )
+ systemd? ( sys-apps/systemd )
+ tcl? ( >=dev-lang/tcl-8.6.13-r1:= )
+ usb? ( virtual/libusb:1 )
+ xml? ( dev-libs/expat )
+ X? (
+ app-accessibility/at-spi2-core:2
+ sys-apps/dbus
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXfixes
+ x11-libs/libXt
+ x11-libs/libXtst
+ )"
+DEPEND="${COMMON_DEPEND}
+ java? ( >=virtual/jdk-1.8:* )
+"
+RDEPEND="${COMMON_DEPEND}
+ java? ( >=virtual/jre-1.8:* )
+"
+BDEPEND="
+ >=dev-lang/tcl-8.6.13-r1
+ virtual/pkgconfig
+ nls? ( virtual/libintl )
+ python? ( dev-python/cython[${PYTHON_USEDEP}] )
+"
+
+HTML_DOCS=( "${S}"/Documents/Manual-BrlAPI/. )
+
+PATCHES=( "${FILESDIR}"/${PN}-6.4-respect-AR.patch )
+
+src_prepare() {
+ default
+
+ java-pkg-opt-2_src_prepare
+
+ # We run eautoconf instead of using eautoreconf because brltty uses
+ # a custom build system that uses autoconf without the rest of the
+ # autotools.
+ eautoconf
+ use python && python_copy_sources
+}
+
+src_configure() {
+ tc-export AR LD PKG_CONFIG
+
+ export JAVAC=""
+ export JAVA_JNI_FLAGS=""
+ if use java; then
+ export JAVA_HOME="$(java-config -g JAVA_HOME)"
+ export JAVAC_HOME="${JAVA_HOME}/bin"
+ export JAVA_JNI_FLAGS="$(java-pkg_get-jni-cflags)"
+ export JAVAC="$(java-pkg_get-javac) -encoding UTF-8 $(java-pkg_javac-args)"
+ fi
+
+ # Override bindir for backward compatibility.
+ # Also override localstatedir so that the lib/brltty directory is installed
+ # correctly.
+ # Disable stripping since we do that ourselves.
+ local myconf=(
+ --bindir="${EPREFIX}"/bin
+ --htmldir="${EPREFIX}"/usr/share/doc/"${P}"/html
+ --localstatedir="${EPREFIX}"/var
+ --runstatedir="${EPREFIX}"/run
+ # the next two lines should be removed once support is added.
+ --disable-emacs-bindings
+ --disable-lua-bindings
+ # Python bindings are built separately per-impl
+ --disable-python-bindings
+ --disable-stripping
+ --with-updatable-directory="${EPREFIX}"/var/lib/brltty
+ --with-writable-directory="${EPREFIX}"/run/brltty
+ --with-privilege-parameters=lx:user=brltty
+ $(use_enable api)
+ $(use_with beeper beep-package)
+# $(use_enable emacs emacs-bindings)
+ $(use_with fm fm-package)
+ $(use_enable gpm)
+ $(use_enable iconv)
+ $(use_enable icu)
+ $(use_enable java java-bindings)
+ $(use_enable louis liblouis)
+# $(use_enable lua lua-bindings)
+ $(use_with midi midi-package)
+ $(use_enable nls i18n)
+ $(use_enable ocaml ocaml-bindings)
+ $(use_with pcm pcm-package)
+ $(use_enable policykit polkit)
+ $(use_enable speech speech-support)
+ $(use_with systemd service-package)
+ $(use_enable tcl tcl-bindings)
+ $(use_enable xml expat)
+ $(use_enable X x)
+ $(use_with bluetooth bluetooth-package)
+ $(use_with ncurses curses)
+ $(use_with usb usb-package)
+ )
+ # disable espeak since we use espeak-ng
+ use speech && myconf+=( --with-speech-driver=-es )
+
+ econf "${myconf[@]}"
+
+ if use python; then
+ python_configure() {
+ econf "${myconf[@]}" --enable-python-bindings PYTHON="${PYTHON}"
+ }
+ python_foreach_impl run_in_build_dir python_configure
+ fi
+}
+
+src_compile() {
+ emake -j1 JAVA_JNI_FLAGS="${JAVA_JNI_FLAGS}" JAVAC="${JAVAC}"
+
+ if use python; then
+ python_build() {
+ emake -C "${BUILD_DIR}"/Bindings/Python -j1
+ }
+ python_foreach_impl run_in_build_dir python_build
+ fi
+}
+
+src_install() {
+ if use ocaml; then
+ findlib_src_preinst
+ fi
+
+ emake -j1 INSTALL_ROOT="${D}" OCAML_LDCONF= install
+
+ if use python; then
+ python_install() {
+ emake -C "${BUILD_DIR}"/Bindings/Python -j1 INSTALL_ROOT="${D}" install
+ }
+ python_foreach_impl run_in_build_dir python_install
+ fi
+
+ if use java; then
+ java-pkg_doso Bindings/Java/libbrlapi_java.so
+ java-pkg_dojar Bindings/Java/brlapi.jar
+ fi
+
+ insinto /etc
+ doins Documents/brltty.conf
+ newinitd "${FILESDIR}"/brltty.initd brltty
+ emake -C Autostart/Systemd -j1 INSTALL_ROOT="${ED}" install
+ emake -C Autostart/Udev -j1 INSTALL_ROOT="${ED}" install
+
+ dodoc Documents/{CONTRIBUTORS,ChangeLog,HISTORY,README*,TODO}
+ if use doc; then
+ HTML_DOCS="doc/Manual-BRLTTY" einstalldocs
+ fi
+
+ keepdir /var/lib/BrlAPI
+ rm -fr "${ED}/run" || die
+ find "${ED}" -name '*.a' -delete || die
+}
+
+pkg_postinst() {
+ tmpfiles_process ${PN}.conf
+
+ elog "please be sure ${EROOT}/etc/brltty.conf is correct for your system."
+ elog
+ elog "To make brltty start on boot on an OpenRC system, type this command:"
+ elog "# rc-update add brltty boot"
+ elog
+ elog "If you are using systemd, type this command:"
+ elog "# systemctl daemon-reload"
+ elog
+ elog "Please reload udev by typing:"
+ elog "# udevadm control --reload"
+}