summaryrefslogtreecommitdiff
path: root/app-admin/apachetop
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/apachetop')
-rw-r--r--app-admin/apachetop/Manifest3
-rw-r--r--app-admin/apachetop/apachetop-0.19.7.ebuild6
-rw-r--r--app-admin/apachetop/files/apachetop-0.19.7-c++17.patch90
3 files changed, 97 insertions, 2 deletions
diff --git a/app-admin/apachetop/Manifest b/app-admin/apachetop/Manifest
index 8037c86453ab..a69ae36db182 100644
--- a/app-admin/apachetop/Manifest
+++ b/app-admin/apachetop/Manifest
@@ -1,3 +1,4 @@
+AUX apachetop-0.19.7-c++17.patch 2309 BLAKE2B 3cc4cae51d25ed559d4c463dd296f319da835aad9de74a09baa0b0cbba8519671d56e134cab8ad922ba689bd6b21507cd72c77525eef0948da103f334f174888 SHA512 18a304e446a35177f21b1af108bcf3c9fda45f22851325c783f6fc8b43851b4e63db71fc537b0a7e2ab9cb908e15193b100708d503b9a928da5edadd3b412038
DIST apachetop-0.19.7.tar.gz 132665 BLAKE2B 248247c361d1585de68a0a9adae22f98db72991babfb4a75f01fa67ef28443a3c04cf1da9c1ea34ed923599955b58959528cc9e0a881fbb7b463b1d64c0cb7bd SHA512 40d546facee23a9914483c06323940e219602518751d80f729d835c4dbf991c7d1dd9bcebcaa4ca6a2d64799d48c8a00d421bc324afc2959691c962113386969
-EBUILD apachetop-0.19.7.ebuild 668 BLAKE2B 0ae03e770fb0b827324687ad574b78d40f33b51f7a378504aaa9f535b214acc1d124d13da2d7b9055f9520d90197e4891acb590c1c3811118a6c0a65f0c6ab99 SHA512 57939a133aeb63182aba31998b982ebd9d86371f7e9d236251ce1bdc8074fe469190d62fdb9b93eaa87020274586c0f49b4ee9bd0ae2b048a124009ffed73634
+EBUILD apachetop-0.19.7.ebuild 721 BLAKE2B 56c4ad6a76a58eaf7e42c50795e66105ff1544acb087de4833129d1bac37b4059620fff711b7a236e3921ca0ab181adac7456cfe688f8fd936777d035b146eb7 SHA512 b0983f0849c934c45a22ccddce2785dd9064f12e4d3f457229c984925aa26669a863813b4de393078e22dec8e1f51c443b0dd880d8c9d167b62b40fbcc57d1f2
MISC metadata.xml 249 BLAKE2B 141880499487b29052f0a977f506fd9967e84ee48965a1abd8ea7c12c56246dd1359723fed5680948bf643040e4c1c01822ee9f39408ff303d71ce2831582fe5 SHA512 dfa5bd639db93c8b76c0aa86bcaae906f3d5eb47f0da64ba522b189a7fd8b5f2c042af6c7c1c8864247f89d88a4e8401b2a5584c85ca2afb18f5c50650d504aa
diff --git a/app-admin/apachetop/apachetop-0.19.7.ebuild b/app-admin/apachetop/apachetop-0.19.7.ebuild
index 816b03798ef0..aaf86e4822f9 100644
--- a/app-admin/apachetop/apachetop-0.19.7.ebuild
+++ b/app-admin/apachetop/apachetop-0.19.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,10 @@ RDEPEND="
DEPEND="${RDEPEND}"
BDEPEND="virtual/pkgconfig"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.19.7-c++17.patch
+)
+
src_configure() {
econf \
--with-logfile="${EPREFIX}"/var/log/apache2/access_log \
diff --git a/app-admin/apachetop/files/apachetop-0.19.7-c++17.patch b/app-admin/apachetop/files/apachetop-0.19.7-c++17.patch
new file mode 100644
index 000000000000..8ec6508b9e08
--- /dev/null
+++ b/app-admin/apachetop/files/apachetop-0.19.7-c++17.patch
@@ -0,0 +1,90 @@
+https://github.com/tessus/apachetop/pull/13
+
+From f89ae55bb09eb1a67fc73555d149fb85f82bfbd6 Mon Sep 17 00:00:00 2001
+From: Sam James <sam@gentoo.org>
+Date: Tue, 14 Feb 2023 03:34:36 +0000
+Subject: [PATCH] Fix C++17 compatibility (drop register keyword)
+
+register doesn't do anything in any reasonable C++ compiler anyway, but
+it was deprecated in C++14 and removed in C++17. Without this, apachetop
+will fail to compile with Clang 16 which defaults to -std=c++17.
+
+Bug: https://bugs.gentoo.org/894186
+--- a/src/inlines.cc
++++ b/src/inlines.cc
+@@ -4,10 +4,10 @@
+ #define ONE_EIGHTH 4
+ #define HIGH_BITS (~((unsigned int)(~0) >> ONE_EIGHTH))
+
+-inline unsigned int StringHash(register const char *str)
++inline unsigned int StringHash(const char *str)
+ {
+- register unsigned int val;
+- register unsigned int i;
++ unsigned int val;
++ unsigned int i;
+
+ for (val = 0; *str; str++)
+ {
+@@ -19,9 +19,9 @@ inline unsigned int StringHash(register const char *str)
+ return val;
+ }
+
+-inline unsigned int QuickHash(register const char *str)
++inline unsigned int QuickHash(const char *str)
+ {
+- register unsigned int val, tmp;
++ unsigned int val, tmp;
+
+ for(val = 0 ; *str ; str++)
+ {
+@@ -32,7 +32,7 @@ inline unsigned int QuickHash(register const char *str)
+ return val;
+ }
+
+-inline unsigned long TTHash(register const char *str)
++inline unsigned long TTHash(const char *str)
+ {
+ unsigned long hash = 5381;
+ int c;
+--- a/src/ohtbl.cc
++++ b/src/ohtbl.cc
+@@ -13,7 +13,7 @@ static int primes[] = {101, 241, 499, 1009, 2003, 3001, 4001, 5003,
+
+ int OAHash::getNextPrime(int size)
+ {
+- register int *prime;
++ int *prime;
+ for (prime = &primes[0] ; *prime ; prime++)
+ if (*prime > size)
+ return *prime;
+@@ -51,7 +51,7 @@ void OAHash::destroy(void)
+
+ void *OAHash::insert(char *key, void *data)
+ {
+- register unsigned int p, i;
++ unsigned int p, i;
+ void *d;
+
+ // Do not exceed the number of positions in the table.
+@@ -81,7 +81,7 @@ void *OAHash::insert(char *key, void *data)
+
+ int OAHash::remove(char *key)
+ {
+- register unsigned int p, i;
++ unsigned int p, i;
+
+ for (i = 0; i < positions; ++i)
+ {
+@@ -108,7 +108,7 @@ int OAHash::remove(char *key)
+
+ void *OAHash::lookup(char *key)
+ {
+- register unsigned int p, i;
++ unsigned int p, i;
+
+ for (i = 0; i < positions; ++i)
+ {
+--
+2.39.1
+