summaryrefslogtreecommitdiff
path: root/app-admin/aws-session-manager-plugin
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/aws-session-manager-plugin')
-rw-r--r--app-admin/aws-session-manager-plugin/Manifest3
-rw-r--r--app-admin/aws-session-manager-plugin/aws-session-manager-plugin-1.2.694.0.ebuild33
-rw-r--r--app-admin/aws-session-manager-plugin/metadata.xml12
3 files changed, 48 insertions, 0 deletions
diff --git a/app-admin/aws-session-manager-plugin/Manifest b/app-admin/aws-session-manager-plugin/Manifest
new file mode 100644
index 000000000000..5aa3a18806a6
--- /dev/null
+++ b/app-admin/aws-session-manager-plugin/Manifest
@@ -0,0 +1,3 @@
+DIST aws-session-manager-plugin-1.2.694.0.tar.gz 35491825 BLAKE2B 134c4a83a5e906206bd0665509d96ed77d5f2c2ea3ca58d9ba776328a36c1eb018674d77d63719c6ba2d00006a60d8e6ccf62f828fca84fdfe7b6b3d5a2a22b9 SHA512 64372b552a7e6d534de886ea1fba26292c1ff71fdc658becbc3ea0ecf7e000de0c69a931ddcaf3d44f50ddc9c331233b169575534d3a46e2cdd9c711d2e21483
+EBUILD aws-session-manager-plugin-1.2.694.0.ebuild 854 BLAKE2B cc3b63a14fa84580b4b5145081c601ca331d3ef71d0829a6280feea599273af2a680764657ce65365b1fdbd95743934bd8eaa928658954f423721b186552dc93 SHA512 8cbbf6d3972b821035e53bf12b1926372d4139ccd9cd6ebffe94c8baf92a2d9638287ce213427cb19cf2670d21f096bebd47b61425c7c4747e51025b34deef50
+MISC metadata.xml 443 BLAKE2B 6eaf1028fe3289e5cac3978eeb4a0efadf105e584118c638246b36be26da551233945c67ea0b416ecad987d13d7c09ecf6f62f361c42807e81d630fb1d6ca15c SHA512 f185def4db1a8555541e195fe3cf450e3fd4f78754cb4d18379665c0137ec976c1e57e30311bd1d8f2a8db23072d72b378d2727a8008240e7d184ee78ce042e3
diff --git a/app-admin/aws-session-manager-plugin/aws-session-manager-plugin-1.2.694.0.ebuild b/app-admin/aws-session-manager-plugin/aws-session-manager-plugin-1.2.694.0.ebuild
new file mode 100644
index 000000000000..9246a7dcc5be
--- /dev/null
+++ b/app-admin/aws-session-manager-plugin/aws-session-manager-plugin-1.2.694.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit go-module systemd
+
+DESCRIPTION="AWS Session Manager Plugin for aws-cli"
+HOMEPAGE="https://docs.aws.amazon.com/systems-manager/latest/userguide/session-manager.html
+ https://github.com/aws/session-manager-plugin"
+SRC_URI="https://github.com/aws/session-manager-plugin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S=${WORKDIR}/${P#aws-}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_prepare() {
+ default
+ sed -e '/^build-linux/s/ checkstyle//' -i makefile || die
+}
+
+src_compile() {
+ emake GO_BUILD="go build" build-linux-${GOARCH}
+}
+
+src_install() {
+ dobin bin/linux_${GOARCH}/ssmcli bin/linux_${GOARCH}_plugin/session-manager-plugin
+ local DOCS=( README.md RELEASENOTES.md )
+ einstalldocs
+
+ systemd_dounit packaging/linux/ssmcli.service
+}
diff --git a/app-admin/aws-session-manager-plugin/metadata.xml b/app-admin/aws-session-manager-plugin/metadata.xml
new file mode 100644
index 000000000000..29b1745e8d0f
--- /dev/null
+++ b/app-admin/aws-session-manager-plugin/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>arthurzam@gentoo.org</email>
+ <name>Arthur Zamarin</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">aws/session-manager-plugin</remote-id>
+ <changelog>https://github.com/aws/session-manager-plugin/blob/mainline/RELEASENOTES.md</changelog>
+ </upstream>
+</pkgmetadata>