summaryrefslogtreecommitdiff
path: root/app-admin/awscli
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/awscli')
-rw-r--r--app-admin/awscli/Manifest2
-rw-r--r--app-admin/awscli/awscli-1.37.22.ebuild95
2 files changed, 97 insertions, 0 deletions
diff --git a/app-admin/awscli/Manifest b/app-admin/awscli/Manifest
index 65a1cde694ff..8de1948e0131 100644
--- a/app-admin/awscli/Manifest
+++ b/app-admin/awscli/Manifest
@@ -1,7 +1,9 @@
DIST aws-cli-1.37.11.gh.tar.gz 2900600 BLAKE2B eed7e50f8b481fa3f7ff1cbb4d6c953545b6d5285decd84ed75b29f89c5a182ed9db299d9cbba8ad75ef6c31da25f80559c55bc9a868d25cf6dea815bd57265e SHA512 a445764336804219cbe18a5f2b929c956c67d63958b4b01b7a4a263801061223941b92e551f223d4966a68d95c711933db0de2e6043c4c85e79376b973088c51
DIST aws-cli-1.37.16.gh.tar.gz 2903703 BLAKE2B 0d3333bef89222e9e84de2c469a98c6fd19177ba6c7e69278e43f459f1909d67e07cdc4150189dd3fd2ce1573ae43a22c944d172738de6102ecf7c7ea00404cf SHA512 d9916ecfedd8bd9086608b6350f95374efad96f3af6adc8b372a254021e4b9f00c43a7c5759cd74f20082f60806fc6eb13d8daf7569fad303995f6d180958cb9
DIST aws-cli-1.37.21.gh.tar.gz 2907762 BLAKE2B e42e9aed28ef3cee1b83f2e57f90ce81a9894bc23a960fef487096ce8b8bab16d23121658aed0547070919ae78a0476176f9517d583a84be90bb016c7cdd9bf7 SHA512 3c7b347627b799d7a3edc7a8cae3d6110ec3cc5bfcdecc247876135faebc2235546a514afbdaf95fec50cfe787ca30b125cae7a8e7be84134d83493a0f869b1a
+DIST aws-cli-1.37.22.gh.tar.gz 2907598 BLAKE2B 00555a7fb5bbd4c527de2be1b0dc17b0de23e0aed9f9de8ef584e427632bb30da411b4e7d7a2deeb51c768dad00a3463542c7eac302080dc94b024d6e71c1088 SHA512 886ccbfe6536312129b0059f26eb81d0d3e334014740516f33c3b648cd1bb3e41482c99bb10639fb3e7e84d730d7dcb698500b65536ee9a9c7f07267d4e82fd6
EBUILD awscli-1.37.11.ebuild 3162 BLAKE2B 099b63681a7300c07c777d38f73edb68bb3d6421c65bf17e778a168441dcdd363e259fc399f7a83598e536bf27f534ccfdf960d1b356f180771b4774962df246 SHA512 662f08a57b1fe95a8fed4bd9c477b865526debd60be4d8164ef0a8fdeb7c4ef0cd71aef17b16717fbf189db283c13ddc13a3ee0c25f0541888f829b0449b134f
EBUILD awscli-1.37.16.ebuild 3169 BLAKE2B 5e19b6d6b837a3f62a7f54c25b76d2dcebbd709ada36d473cee53d0cfc2aa7b3de92cb12db09be4fafbd0b5c303761436b25bf3b4afe16cf0119481959e2b9c2 SHA512 0d30f1cd05a160c7d70f85cc5887d9333b9512421c74d394cae05799229c74c2edb307434f90b64353cd8963b85889546df20e3bf5e7a3fa8953ae2b4a6cecdb
EBUILD awscli-1.37.21.ebuild 3169 BLAKE2B 5e19b6d6b837a3f62a7f54c25b76d2dcebbd709ada36d473cee53d0cfc2aa7b3de92cb12db09be4fafbd0b5c303761436b25bf3b4afe16cf0119481959e2b9c2 SHA512 0d30f1cd05a160c7d70f85cc5887d9333b9512421c74d394cae05799229c74c2edb307434f90b64353cd8963b85889546df20e3bf5e7a3fa8953ae2b4a6cecdb
+EBUILD awscli-1.37.22.ebuild 3169 BLAKE2B 5e19b6d6b837a3f62a7f54c25b76d2dcebbd709ada36d473cee53d0cfc2aa7b3de92cb12db09be4fafbd0b5c303761436b25bf3b4afe16cf0119481959e2b9c2 SHA512 0d30f1cd05a160c7d70f85cc5887d9333b9512421c74d394cae05799229c74c2edb307434f90b64353cd8963b85889546df20e3bf5e7a3fa8953ae2b4a6cecdb
MISC metadata.xml 385 BLAKE2B 5accfb180a91179cc6df539d42d1de06be3ebfec73f3edb719f5d59576103b9a8cb0c7c524c1042630e0cf99f068939a19f04c7b1b4a2acf9e072369df80d913 SHA512 ccb3d516326c5dbdf53068372ce25baecc137d21a04516374362212b969cc928dacbf743b4953da33f28482905798f069d09d19c88d9913f2b32648db25115ab
diff --git a/app-admin/awscli/awscli-1.37.22.ebuild b/app-admin/awscli/awscli-1.37.22.ebuild
new file mode 100644
index 000000000000..4a8e0ae852e0
--- /dev/null
+++ b/app-admin/awscli/awscli-1.37.22.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit bash-completion-r1 distutils-r1
+
+MY_P=aws-cli-${PV}
+DESCRIPTION="Universal Command Line Environment for AWS"
+HOMEPAGE="
+ https://github.com/aws/aws-cli/
+ https://pypi.org/project/awscli/
+"
+SRC_URI="
+ https://github.com/aws/aws-cli/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+# botocore is x.(y-1).z
+BOTOCORE_PV="$(ver_cut 1).$(( $(ver_cut 2) - 1)).$(ver_cut 3-)"
+RDEPEND="
+ >=dev-python/botocore-${BOTOCORE_PV}[${PYTHON_USEDEP}]
+ dev-python/colorama[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/rsa[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.11.0[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ !app-admin/awscli-bin
+"
+BDEPEND="
+ test? (
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pytest-forked[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+ # strip overzealous upper bounds on requirements
+ sed -i -e 's:,<[0-9.]*::' -e 's:==:>=:' setup.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local serial_tests=(
+ tests/functional/ecs/test_execute_command.py::TestExecuteCommand::test_execute_command_success
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_{fails,success}
+ tests/functional/ssm/test_start_session.py::TestSessionManager::test_start_session_with_new_version_plugin_success
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestDotNetLogin::test_login_dotnet_sources_listed_with_backtracking_windows
+ tests/unit/customizations/codeartifact/test_adapter_login.py::TestNuGetLogin::test_login_nuget_sources_listed_with_backtracking
+ tests/unit/customizations/ecs/test_executecommand_startsession.py::TestExecuteCommand::test_execute_command_success
+ tests/unit/customizations/test_sessionmanager.py
+ tests/unit/test_compat.py::TestIgnoreUserSignals
+ tests/unit/test_help.py
+ tests/unit/test_utils.py::TestIgnoreCtrlC::test_ctrl_c_is_ignored
+ )
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ EPYTEST_XDIST= epytest "${serial_tests[@]}"
+
+ local EPYTEST_DESELECT=(
+ "${serial_tests[@]}"
+
+ # flaky (some ordering?)
+ tests/functional/s3/test_cp_command.py::TestCPCommand::test_multipart_upload_with_checksum_algorithm_crc32
+ )
+ # integration tests require AWS credentials and Internet access
+ epytest tests/{functional,unit}
+}
+
+python_install_all() {
+ newbashcomp bin/aws_bash_completer aws
+
+ insinto /usr/share/zsh/site-functions
+ newins bin/aws_zsh_completer.sh _aws
+
+ distutils-r1_python_install_all
+
+ rm "${ED}"/usr/bin/{aws.cmd,aws_bash_completer,aws_zsh_completer.sh} || die
+}