summaryrefslogtreecommitdiff
path: root/app-admin/cdist
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/cdist')
-rw-r--r--app-admin/cdist/Manifest5
-rw-r--r--app-admin/cdist/cdist-4.6.1.ebuild24
-rw-r--r--app-admin/cdist/cdist-4.7.3.ebuild24
-rw-r--r--app-admin/cdist/metadata.xml15
4 files changed, 68 insertions, 0 deletions
diff --git a/app-admin/cdist/Manifest b/app-admin/cdist/Manifest
new file mode 100644
index 000000000000..07cf36281721
--- /dev/null
+++ b/app-admin/cdist/Manifest
@@ -0,0 +1,5 @@
+DIST cdist-4.6.1.tar.gz 454461 BLAKE2B 5cf5ba376b981feb6d740f53b4c4cdf51a8f0b4d4422db2c2c7312dd1288e006bfcae7c3459707e361536002a2a6b49bb8ef836783fac8167834978fb5737683 SHA512 f0c3759d00221fbd36d7662de6ccc57fc0070b8aee6a0d80e6bab6f41215c537a1cf1a6ec9fdebf81c45ad8126b8e730a14be8f1286d5baf5f4a5672611e31dc
+DIST cdist-4.7.3.tar.gz 497537 BLAKE2B e743e49291d6b212810911607ac149a54e6c8423841c4149f620d2127bbeb2fdce7d5ceff76572f1599a3a3326944066ba336f93f25de50d98ad972188562709 SHA512 9b69e257c816d515e4d94bc73d26ca1cfb2343fc4fc8298aadfbb82417aa28c9759831c304b90d6427e275988442cd19681e455c98757c87426d0435dd90ae41
+EBUILD cdist-4.6.1.ebuild 596 BLAKE2B 68bdf8cedb9d41f9ae5b276c1c8f81bc71096abefdab55f9abe9def93e4fc33e9ce170faa5240fd9006b23ef363ef9d2c9c446a6be1d7b7d61c723a7b6f9a37e SHA512 95f4fadaf35314bc667a3f6eafade25820dd3fbe07c96158285c35f1fee2681f577135c10e954ad518b56780ec86c5a4e9db579563488335cda9252d1b70d802
+EBUILD cdist-4.7.3.ebuild 596 BLAKE2B 68bdf8cedb9d41f9ae5b276c1c8f81bc71096abefdab55f9abe9def93e4fc33e9ce170faa5240fd9006b23ef363ef9d2c9c446a6be1d7b7d61c723a7b6f9a37e SHA512 95f4fadaf35314bc667a3f6eafade25820dd3fbe07c96158285c35f1fee2681f577135c10e954ad518b56780ec86c5a4e9db579563488335cda9252d1b70d802
+MISC metadata.xml 443 BLAKE2B 2742628c4f58fc21f1fca78752bce1e6275ec34ca7aa547a39d8a11cf3c7d9c149030078a55383f706053fa3cd70f071d5d5c571f3b009e941cbbc2c29b6c21a SHA512 5d1dbb6742101c7b89662f3edba9d3eb7da595611fbb613a1da1482e76cbf563fdf5fbf227471ca4c90e5a96d62c65433beaf9b90bbc716c7614ea5fe6b5063a
diff --git a/app-admin/cdist/cdist-4.6.1.ebuild b/app-admin/cdist/cdist-4.6.1.ebuild
new file mode 100644
index 000000000000..52491eaacc40
--- /dev/null
+++ b/app-admin/cdist/cdist-4.6.1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A usable configuration management system"
+HOMEPAGE="https://www.nico.schottelius.org/software/cdist/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/dist/html/*.html docs/dist/html/man{1,7}/*.html )
+ distutils-r1_python_install_all
+
+ doman docs/dist/man/man1/*.1 docs/dist/man/man7/*.7
+}
diff --git a/app-admin/cdist/cdist-4.7.3.ebuild b/app-admin/cdist/cdist-4.7.3.ebuild
new file mode 100644
index 000000000000..52491eaacc40
--- /dev/null
+++ b/app-admin/cdist/cdist-4.7.3.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A usable configuration management system"
+HOMEPAGE="https://www.nico.schottelius.org/software/cdist/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/dist/html/*.html docs/dist/html/man{1,7}/*.html )
+ distutils-r1_python_install_all
+
+ doman docs/dist/man/man1/*.1 docs/dist/man/man7/*.7
+}
diff --git a/app-admin/cdist/metadata.xml b/app-admin/cdist/metadata.xml
new file mode 100644
index 000000000000..3bc61f181389
--- /dev/null
+++ b/app-admin/cdist/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>nerve@ipwar.ch</email>
+ <name>Daniel Heule</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">cdist</remote-id>
+ </upstream>
+</pkgmetadata>