summaryrefslogtreecommitdiff
path: root/app-admin/doas/doas-6.0.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/doas/doas-6.0.ebuild')
-rw-r--r--app-admin/doas/doas-6.0.ebuild39
1 files changed, 0 insertions, 39 deletions
diff --git a/app-admin/doas/doas-6.0.ebuild b/app-admin/doas/doas-6.0.ebuild
deleted file mode 100644
index 0249bca14a16..000000000000
--- a/app-admin/doas/doas-6.0.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-inherit toolchain-funcs
-
-DESCRIPTION="Run commands as super user or another user, alternative to sudo from OpenBSD"
-
-MY_PN=OpenDoas
-MY_P=${MY_PN}-${PV}
-HOMEPAGE="https://github.com/Duncaen/OpenDoas"
-SRC_URI="https://github.com/Duncaen/${MY_PN}/archive/v${PV}.tar.gz -> ${MY_P}.tar.gz"
-S="${WORKDIR}"/${MY_P}
-
-LICENSE="ISC"
-SLOT="0"
-KEYWORDS="amd64 arm"
-IUSE="pam"
-
-RDEPEND="pam? ( virtual/pam )"
-DEPEND="${RDEPEND}
- virtual/yacc"
-
-src_prepare()
-{
- default
- sed -i 's/-Werror //' Makefile || die
-}
-
-src_configure()
-{
- tc-export CC AR
- ./configure \
- --prefix="${EPREFIX}"/usr \
- --sysconfdir="${EPREFIX}"/etc \
- $(use_with pam) \
- || die
-}