summaryrefslogtreecommitdiff
path: root/app-admin/linode-cli
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/linode-cli')
-rw-r--r--app-admin/linode-cli/Manifest2
-rw-r--r--app-admin/linode-cli/linode-cli-5.56.0.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/app-admin/linode-cli/Manifest b/app-admin/linode-cli/Manifest
index e6011bdbb079..6006c71a7efe 100644
--- a/app-admin/linode-cli/Manifest
+++ b/app-admin/linode-cli/Manifest
@@ -1,5 +1,7 @@
DIST linode_cli-5.54.0.tar.gz 153961 BLAKE2B ae147c7c29532d53e8230e8374acb5727791f07f3177720637d7b23d1169821b2a65975b6e22f45bb53f69d241525ecb081a18f854d3d904da9de406f27f146f SHA512 7cad0e899ebced5c27923f4b8ea6fc4c854f90f7925ff5e8e010565ec51f20c75976a0efacfebceb78c4befa0e64ea0a2c896bb82f541903413fe96c8b0c68e1
DIST linode_cli-5.55.0.tar.gz 159746 BLAKE2B 1ef914ec316bebb40961f075c528d8311c21030bcc643e45e18e187cce8d52f2a79629be7482778e5f0061c3db143685b5899e7e0c563f0565bbad3390dc3783 SHA512 37b88fbdbc66a6057a3b50379928d7f0547136aa8d068109b2dd3d2c6969698598a26c84b1f7494952795dc52a7ab05e2240680d86e88c85007df1e53445052d
+DIST linode_cli-5.56.0.tar.gz 160792 BLAKE2B 25d2099d0363e699444245a939ede518530f1dda63a063db74b34650f7f7d76cf1f0d630cc01ca6dbeaed659a10f1429792d06615db4f773669234267f608d24 SHA512 5f3b075479a00b3d8c210c98040029bf44b10dc505a711e373bab49b53556a4ae4d26799a998c0354b562bfa1bbdbfa6d4b965c52d8c9bd57fae8d3c1eb27e72
EBUILD linode-cli-5.54.0.ebuild 1338 BLAKE2B 8cdcd6d7ad933ac3ee00ad19a9f900961de75404b4e9b36f8043cca9e76e6db846c1ec4a9490901edd15cba501fcf9671a808444f144962b63574c60281343cd SHA512 396a0108dfddab2e2c5ba57caec6d599d3723807cce301a2545415f0e0c625e6f0c0e846b2b243bba459695928c360c35ed04ea027ac236c450530458c6893d9
EBUILD linode-cli-5.55.0.ebuild 1338 BLAKE2B 8cdcd6d7ad933ac3ee00ad19a9f900961de75404b4e9b36f8043cca9e76e6db846c1ec4a9490901edd15cba501fcf9671a808444f144962b63574c60281343cd SHA512 396a0108dfddab2e2c5ba57caec6d599d3723807cce301a2545415f0e0c625e6f0c0e846b2b243bba459695928c360c35ed04ea027ac236c450530458c6893d9
+EBUILD linode-cli-5.56.0.ebuild 1338 BLAKE2B be1fab9cdec25c42418e83f0247f5fb926486643e78cf6cb3c2e4c2ad3030fac672ebeb7bce3bfc6b86ad8d08aa9b1deb597ce166390953c56cb07b8ae3e1f2a SHA512 65b66bfe07cf7f17711a8c29dd3dc91fab6b3af3b4b7219200e7dbc6f0030feabd7afc21d12f5f37824b2dfd72538fb4499e677380a04f6ed3c3ed7cad23c32e
MISC metadata.xml 483 BLAKE2B 7b3a4b824e16ba32424777359d0daf09d17cc498a06f9ce5acfd7baec80ffea26220145676f37edfe46302257fd0a2bc5071d60f955dc19cda582419b2027f5c SHA512 33c8fae2235a7a6d2653a4db3341b2d69e390ed6dfa33868dd7e6b3a384f78013ae3c42a91d8eddd25929086f7705ce0869a34e28eedadb497e286ae59570be4
diff --git a/app-admin/linode-cli/linode-cli-5.56.0.ebuild b/app-admin/linode-cli/linode-cli-5.56.0.ebuild
new file mode 100644
index 000000000000..1353a61b0c36
--- /dev/null
+++ b/app-admin/linode-cli/linode-cli-5.56.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 2023-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..13} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1 pypi shell-completion
+
+DESCRIPTION="Official command-line interface for interacting with the Linode API"
+HOMEPAGE="https://github.com/linode/linode-cli https://www.linode.com/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# Tests require network, a linode account and an API key.
+# WARNING: tests will incur costs and will wipe the account.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/boto3[${PYTHON_USEDEP}]
+ >=dev-python/linode-metadata-0.3[${PYTHON_USEDEP}]
+ dev-python/openapi3[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ <dev-python/urllib3-3[${PYTHON_USEDEP}]
+"
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ PYTHONPATH=. ${EPYTHON} linodecli completion bash > "${T}/${PN}".bash || die
+ PYTHONPATH=. ${EPYTHON} linodecli completion fish > "${T}/${PN}".fish || die
+
+ newbashcomp "${T}/${PN}".bash ${PN}
+ newfishcomp "${T}/${PN}".fish ${PN}
+
+ dosym ${PN} "$(get_bashcompdir)"/linode
+ dosym ${PN} "$(get_bashcompdir)"/lin
+ dosym ${PN} "$(get_fishcompdir)"/linode
+ dosym ${PN} "$(get_fishcompdir)"/lin
+}