summaryrefslogtreecommitdiff
path: root/app-admin/lsyncd/lsyncd-2.2.3.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/lsyncd/lsyncd-2.2.3.ebuild')
-rw-r--r--app-admin/lsyncd/lsyncd-2.2.3.ebuild23
1 files changed, 19 insertions, 4 deletions
diff --git a/app-admin/lsyncd/lsyncd-2.2.3.ebuild b/app-admin/lsyncd/lsyncd-2.2.3.ebuild
index 67ccfb4ab94d..705a0e4067e6 100644
--- a/app-admin/lsyncd/lsyncd-2.2.3.ebuild
+++ b/app-admin/lsyncd/lsyncd-2.2.3.ebuild
@@ -1,10 +1,13 @@
-# Copyright 1999-2018 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI="6"
+EAPI=7
CMAKE_IN_SOURCE_BUILD="YES_PLEASE_OMG"
-inherit cmake-utils
+LUA_COMPAT=( lua5-{2,3} )
+LUA_REQ_USE="deprecated"
+
+inherit cmake lua-single
DESCRIPTION="Live Syncing (Mirror) Daemon"
HOMEPAGE="https://github.com/axkibe/lsyncd"
@@ -14,15 +17,27 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-CDEPEND=">=dev-lang/lua-5.2[deprecated]"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+
+CDEPEND="${LUA_DEPS}"
DEPEND="${CDEPEND}
app-text/asciidoc
virtual/pkgconfig"
RDEPEND="${CDEPEND}
net-misc/rsync"
+# Both lua and luac are invoked at build time
+BDEPEND="${CDEPEND}"
PATCHES=(
+ "${FILESDIR}"/${PN}-2.2.3-cmake_lua_version.patch
"${FILESDIR}"/${PN}-2.3.3-mandir.patch
)
S=${WORKDIR}/${PN}-release-${PV}
+
+src_configure() {
+ local mycmakeargs=(
+ -DLUA_ABI_VERSION=$(ver_cut 1-2 $(lua_get_version))
+ )
+ cmake_src_configure
+}