summaryrefslogtreecommitdiff
path: root/app-admin/pwcrypt
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/pwcrypt')
-rw-r--r--app-admin/pwcrypt/Manifest5
-rw-r--r--app-admin/pwcrypt/files/pwcrypt-gcc-10.patch66
-rw-r--r--app-admin/pwcrypt/metadata.xml7
-rw-r--r--app-admin/pwcrypt/pwcrypt-1.2.2-r2.ebuild8
4 files changed, 78 insertions, 8 deletions
diff --git a/app-admin/pwcrypt/Manifest b/app-admin/pwcrypt/Manifest
index d211d51b223b..e4f869b3de07 100644
--- a/app-admin/pwcrypt/Manifest
+++ b/app-admin/pwcrypt/Manifest
@@ -1,3 +1,4 @@
+AUX pwcrypt-gcc-10.patch 2031 BLAKE2B 58df1816fd176cd486c46a96a56ad7c814b47d214a71292967fa02a30e5d8ced81d8483ce830993979f0f74ef747017d590955d67252e385a7a7b173a1a4300a SHA512 a0560fdd2f4ad82d3f63dbcba148255e8f451944961bb12e69f9dbe2566f02f3b1d853d2fe69a76c1fa94d0218ec9bc7c0bbafef1528a42f67f36bc3ee6d33be
DIST pwcrypt-1.2.2.tar.gz 36902 BLAKE2B 3cb63bf2a907f4394a7bb5317c7c0bf9ac493de41a54f7107c01a46dea41d32c8e24631f5197e3c62c62d6d44d959f505874e0a3d6ab7c0fc04863165b37ec56 SHA512 41644e82f8306003e9346900d7a961e87a5b8103ebc411cf09b5e0e40d8253b4c38a83db57c60f09d2dd2663ecc2e2edc10ea2b6d095c102ee10ae251b471ddf
-EBUILD pwcrypt-1.2.2-r2.ebuild 603 BLAKE2B ac51bb99c0ab2e51d612cedefa18222b936c353b50233a399108257d7355a2f3355592ffe8906d91e9f1358189d5d470d652027521f51446936c16936d88c7e1 SHA512 88797f0e9d81baf5416ccb14c8ee302ffbb47c09f4dc6f69270acbe71285e2e962e26fa9da7b320a84611382986c6d65166525121aa523e2a1434a922a1d2409
-MISC metadata.xml 221 BLAKE2B 6fb71e3c82061054a0c2d88c1ce8e591d5742628fe53032c9efd2c371ce1e8b0135b00ac91fa1905df39a507d5faa5871fb3a30d167dd46cec581682ba17c8ff SHA512 a11e9bbbabc9ac96985c5dc247e601b065fa762f12bce74224896c27aee34eb908187622bfc849c39c6c722a8ef8ee72b248afc84da1b0eb72f1ff5eeb13bbf0
+EBUILD pwcrypt-1.2.2-r2.ebuild 650 BLAKE2B cab7322ac9222927ff28a6f74c4b2a39db4116ab0e535b6aa105395e82e0142d0d3da7554fff06eb9fbde5d1a52e2965420aac7d07813164679d3df299b0ff07 SHA512 5fda491d896d9562e110f67c861546314b5b48582c70fa6f8d88672928329149becdb109fda87cd5cefcf340d5cc6bef5a1fbd8f9ee1d41f7beb76ca6bf27d8f
+MISC metadata.xml 248 BLAKE2B e581d975884f924f92f81a803547379276565617c24d86f893c0186a4793c1167a36cbd8083261a10ce99839b9e5b5dd29f237bebb644eaef29ced562c9c6310 SHA512 62ab121be05f0603fe52b26ac612943b049bc527ff73401e6ed427622fcfd7f07cf3fabae90ac9e30297692ec4188b1a8bdc1f9104e30d6ed4032a96ffd77cf2
diff --git a/app-admin/pwcrypt/files/pwcrypt-gcc-10.patch b/app-admin/pwcrypt/files/pwcrypt-gcc-10.patch
new file mode 100644
index 000000000000..745c93f5d156
--- /dev/null
+++ b/app-admin/pwcrypt/files/pwcrypt-gcc-10.patch
@@ -0,0 +1,66 @@
+--- a/src/cli-crypt.h
++++ b/src/cli-crypt.h
+@@ -27,16 +27,16 @@
+ #define LSIZE 1024 /* our standard buffer size for static memory */
+
+ /* our global variables */
+-char cleartext_pass[LSIZE]; /* where do we store the initial cleartext of the password */
+-char encrypted_pass[LSIZE]; /* where we stuff our password once it's encrypted */
+-char salt_src[LSIZE]; /* a place we can store text to scramble to get our salt */
+-char salt[LSIZE]; /* the actual salt we end up with using in our call to crypt(); */
++extern char cleartext_pass[LSIZE]; /* where do we store the initial cleartext of the password */
++extern char encrypted_pass[LSIZE]; /* where we stuff our password once it's encrypted */
++extern char salt_src[LSIZE]; /* a place we can store text to scramble to get our salt */
++extern char salt[LSIZE]; /* the actual salt we end up with using in our call to crypt(); */
+
+ /* flags we use to determine how we're doing things */
+-short int md5; /* we doing md5 passwords */
+-short int quiet; /* are we to be quiet */
+-short int debug; /* do we print debug info? */
+-short int do_salt; /* do we need to provide a salt? */
++extern short int md5; /* we doing md5 passwords */
++extern short int quiet; /* are we to be quiet */
++extern short int debug; /* do we print debug info? */
++extern short int do_salt; /* do we need to provide a salt? */
+
+
+ /* from main.c */
+--- a/src/crypt.c
++++ b/src/crypt.c
+@@ -26,7 +26,7 @@
+
+ #include "include.h"
+
+-
++char encrypted_pass[LSIZE];
+
+ short int cr_crypt() {
+ char *cp;
+--- a/src/getopt.c
++++ b/src/getopt.c
+@@ -25,6 +25,13 @@
+
+ #include "include.h"
+
++char cleartext_pass[LSIZE];
++
++short int md5;
++short int quiet;
++short int debug;
++short int do_salt;
++
+ void cr_version(char *me) {
+ /* some quick mutzing around to get the == of `basename $0` */
+ char lme[LSIZE];
+--- a/src/random.c
++++ b/src/random.c
+@@ -27,6 +27,9 @@
+
+ #include "include.h"
+
++char salt_src[LSIZE];
++char salt[LSIZE];
++
+ /* shared amongst the functions in this file */
+ long int rand_file;
+
diff --git a/app-admin/pwcrypt/metadata.xml b/app-admin/pwcrypt/metadata.xml
index 21dc8fdf43ff..7ffc4339bc56 100644
--- a/app-admin/pwcrypt/metadata.xml
+++ b/app-admin/pwcrypt/metadata.xml
@@ -1,7 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer type="person">
- <email>hattya@gentoo.org</email>
- </maintainer>
+ <maintainer type="person">
+ <email>hattya@gentoo.org</email>
+ <name>Akinori Hattori</name>
+ </maintainer>
</pkgmetadata>
diff --git a/app-admin/pwcrypt/pwcrypt-1.2.2-r2.ebuild b/app-admin/pwcrypt/pwcrypt-1.2.2-r2.ebuild
index 7a0b4f3d0921..250ada02cb4d 100644
--- a/app-admin/pwcrypt/pwcrypt-1.2.2-r2.ebuild
+++ b/app-admin/pwcrypt/pwcrypt-1.2.2-r2.ebuild
@@ -1,23 +1,25 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI="7"
inherit toolchain-funcs
DESCRIPTION="An improved version of cli-crypt (encrypts data sent to it from the cli)"
HOMEPAGE="http://xjack.org/pwcrypt/"
-SRC_URI="http://xjack.org/pwcrypt/downloads/${P}.tar.gz"
+SRC_URI="http://xjack.org/${PN}/downloads/${P}.tar.gz"
-LICENSE="GPL-2"
+LICENSE="GPL-2+"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
+PATCHES=( "${FILESDIR}"/${PN}-gcc-10.patch )
DOCS=( CREDITS README )
src_prepare() {
default
+
sed -i "s/make\( \|$\)/\$(MAKE)\1/g" Makefile.in || die
sed -i \
-e "/^LDFLAGS/s/= /= @LDFLAGS@ /" \