summaryrefslogtreecommitdiff
path: root/app-admin/r10k
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/r10k')
-rw-r--r--app-admin/r10k/Manifest3
-rw-r--r--app-admin/r10k/metadata.xml18
-rw-r--r--app-admin/r10k/r10k-1.5.1-r2.ebuild68
3 files changed, 89 insertions, 0 deletions
diff --git a/app-admin/r10k/Manifest b/app-admin/r10k/Manifest
new file mode 100644
index 000000000000..7d3e6c4ba4c8
--- /dev/null
+++ b/app-admin/r10k/Manifest
@@ -0,0 +1,3 @@
+DIST r10k-1.5.1.gem 164864 BLAKE2B 398f656913b9c0b3835d782dec3aa0d7a475dc49ac6fba7734239a795e209048969c1e66575029eae5ac19513ac57e24adbfc839c9f5c0537c82fe0fe65def30 SHA512 4440a893aaa6ec0337f9347b620f92afd93099465c148bfe90cd44c2c6fe29cc8411b8c225044a9547d24a8857b580dcf2ea190bf64fe9ba180d1c5c3832d1dd
+EBUILD r10k-1.5.1-r2.ebuild 2127 BLAKE2B fb14e3b0dc36d26e168d7986e1c421d8e8098e25a513f1fcad8de0dabfbd2d4b4fa0ceae16c1795342dd0de617d7f7fad996d5375ce772304fc862dd891f8b5b SHA512 94eb12be84982b760c32635d0fb74b2e262c6585d87292468caf6b22f60a980a75c2665a923c63cffdf2fbaf7814c78ecec37a3c9b2cd9fb6411928614410b8f
+MISC metadata.xml 696 BLAKE2B 13606b1e280dd0e75f1871c7c749eb67a8e0b455a9f357bf65ffca50547c0811c050a31858fec52c97f3fbc9234222f34372f087660ca65e5a13fd1561d098f1 SHA512 1158620e00396d313aeda263aa479ac878a42162f5c122ca69b26a8fb41d84cbeae688b0c3cda77658edc12056ec17cd12a0c84b95422442ab1bb6aba3cc16df
diff --git a/app-admin/r10k/metadata.xml b/app-admin/r10k/metadata.xml
new file mode 100644
index 000000000000..685e7874f384
--- /dev/null
+++ b/app-admin/r10k/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>vikraman@gentoo.org</email>
+ <name>Vikraman Choudhury</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>sysadmin@gentoo.org</email>
+ <name>Gentoo Sysadmin Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ r10k provides a general purpose toolset for deploying Puppet environments and modules. It implements the Puppetfile format and provides a native implementation of Puppet dynamic environments.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">puppetlabs/r10k</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-admin/r10k/r10k-1.5.1-r2.ebuild b/app-admin/r10k/r10k-1.5.1-r2.ebuild
new file mode 100644
index 000000000000..26d06ae24c0c
--- /dev/null
+++ b/app-admin/r10k/r10k-1.5.1-r2.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+USE_RUBY="ruby23 ruby24"
+
+RUBY_FAKEGEM_RECIPE_TEST="rspec3"
+RUBY_FAKEGEM_TASK_DOC=""
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Puppet environment and module deployment"
+HOMEPAGE="https://github.com/puppetlabs/r10k"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="+git"
+
+ruby_add_rdepend "
+ >=dev-ruby/colored-1.2
+ =dev-ruby/cri-2.7*
+ >=dev-ruby/systemu-2.5.2
+ >=dev-ruby/log4r-1.1.10
+ >=dev-ruby/faraday-0.9.0
+ >=dev-ruby/faraday_middleware-0.9.0
+ >=dev-ruby/faraday_middleware-multi_json-0.0.6
+ >=dev-ruby/multi_json-1.10
+ >=dev-ruby/semantic_puppet-0.1.1
+ >=dev-ruby/json-1.8:0"
+
+ruby_add_bdepend "test? (
+ dev-ruby/archive-tar-minitar
+)"
+
+RDEPEND="${RDEPEND} git? ( >=dev-vcs/git-1.6.6 )"
+
+all_ruby_prepare() {
+ sed -i -e 's/json_pure/json/' \
+ -e '/cri/ s/2\.6\../2.7/' \
+ -e '/systemu/ s/2.5.2/2.5/' \
+ -e '/faraday/ s/0.9.0/0.9/' \
+ -e '/semantic_puppet/ s/~>/>/' \
+ -e '/s.files/d' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+pkg_postinst() {
+ ewarn
+ ewarn "If you are upgrading from 1.1.0 and are using multiple sources, please read"
+ ewarn "this. (If not, feel free to continue with your regularly scheduled day.)"
+ ewarn
+ ewarn "GH-48 (https://github.com/puppetlabs/r10k/issues/48) introduced the ability"
+ ewarn "for environments to be prefixed with the source name so that multiple sources"
+ ewarn "installed into the same directory would not overwrite each other. However"
+ ewarn "prefixing was automatically enabled and would break existing setups where"
+ ewarn "multiple sources were cloned into different directories."
+ ewarn
+ ewarn "Because this introduced a breaking change, SemVer dictates that the automatic"
+ ewarn "prefixing has to be rolled back. Prefixing can be enabled but always defaults"
+ ewarn "to off. If you are relying on this behavior you will need to update your r10k.yaml"
+ ewarn "to enable prefixing on a per-source basis."
+ ewarn
+ ewarn "Please see the issue (https://github.com/puppetlabs/r10k/issues/48) for more"
+ ewarn "information."
+}