summaryrefslogtreecommitdiff
path: root/app-admin/su-exec/su-exec-0.2.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-admin/su-exec/su-exec-0.2.ebuild')
-rw-r--r--app-admin/su-exec/su-exec-0.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/app-admin/su-exec/su-exec-0.2.ebuild b/app-admin/su-exec/su-exec-0.2.ebuild
new file mode 100644
index 000000000000..f51e2f258af4
--- /dev/null
+++ b/app-admin/su-exec/su-exec-0.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="Switch user and group id and exec"
+HOMEPAGE="https://github.com/ncopa/su-exec"
+SRC_URI="https://github.com/ncopa/su-exec/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="static"
+
+src_prepare() {
+ default
+ sed -i -e "s/-Werror//" Makefile || die
+}
+
+src_compile() {
+ CC=$(tc-getCC) emake $(usex static "${PN}-static" "")
+}
+
+src_install() {
+ newbin ${PN}$(usex static "-static" "") ${PN}
+ dodoc README.md
+}