summaryrefslogtreecommitdiff
path: root/app-arch/lunzip/lunzip-1.13.ebuild
diff options
context:
space:
mode:
Diffstat (limited to 'app-arch/lunzip/lunzip-1.13.ebuild')
-rw-r--r--app-arch/lunzip/lunzip-1.13.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/app-arch/lunzip/lunzip-1.13.ebuild b/app-arch/lunzip/lunzip-1.13.ebuild
new file mode 100644
index 000000000000..4f7d48dab0be
--- /dev/null
+++ b/app-arch/lunzip/lunzip-1.13.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="Decompressor for the lzip format, written in C"
+HOMEPAGE="https://www.nongnu.org/lzip/lunzip.html"
+SRC_URI="https://download.savannah.gnu.org/releases/lzip/lunzip/${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+src_configure() {
+ # not autotools-based
+ local myconf=(
+ --prefix="${EPREFIX}"/usr
+ CC="$(tc-getCC)"
+ CPPFLAGS="${CPPFLAGS}"
+ CFLAGS="${CFLAGS}"
+ LDFLAGS="${LDFLAGS}"
+ )
+
+ ./configure "${myconf[@]}" || die
+}